Разработка программы для автоматизации работы кафе

Тип работы:
Курсовая
Предмет:
Программирование


Узнать стоимость

Детальная информация о работе

Выдержка из работы

СОДЕРЖАНИЕ

ВВЕДЕНИЕ

ГЛАВА I. АНАЛИЗ ДЕЯТЕЛЬНОСТИ КАФЕ

1.1 Общие сведения, цели и задачи

1.2 Организационная структура

1.3 Информационная структура

1.4 Функциональная структура

1.5 Информационно-техническое обеспечение

ГЛАВА II. РАЗРАБОТКА ТЕХНИЧЕСКОГО ПРОЕКТА

2.1 Обзор аналогичных систем

2.1.1 Программа ИНПРО: Ресторанный комплекс 8

2.1.2 Программа «Трактиръ: Стандарт ПЛЮС», редакция 4. 4

2.1.3 1C-Рарус: Ресторан+Бар+Кафе, редакция 2

2.1.4 Программа АСТОР: Ресторан 2. 0

2.1.5 Программа КАМИН: Общепит. Версия 3. 0

2.1.6 Программа ИБЦ-Кафе

2.1.7 Программа «Guscom POS»

2.2 Эскиз технического задания

2.3 Логическая модель информационной системы

2.4 Физическая модель

ГЛАВА III. РЕАЛИЗАЦИЯ ПРОЕКТА

3.1 Разработка экранных форм

3.2 Разработка модулей для прикладных решений

3.3 Разработка отчетов

ЗАКЛЮЧЕНИЕ

СПИСОК ИСПОЛЬЗОВАННОЙ ЛИТЕРАТУРЫ

ПРИЛОЖЕНИЯ

ВВЕДЕНИЕ

Кафе -- заведение общественного питания и отдыха, похожее на небольшой ресторан, но с ограниченным по сравнению с рестораном ассортиментом продукции. По ассортименту реализуемой продукции подразделяются на: кофейня, кафе-пекарня (кондитерская), кафе-мороженое, кафе-бар, интернет-кафе, арт-кафе (клуб); по месторасположению: стационарное и уличное; по контингенту: молодёжное, детское, gay-friendly и другие.

Общественное питание играет все возрастающую роль в жизни современного общества. Это обеспечивается изменением технологий переработки продуктов питания, развитием коммуникаций, средств доставки продукции и сырья, интенсификацией многих производственных процессов.

Таким образом, автоматизация деятельности кафе является необходимым и перспективным процессом. Комплексное использование современных информационных технологий позволяет значительно облегчить работу кафе.

Функциональные возможности программы должны охватывать все возможные ситуации в работе кафе. Программа должна поддерживать ведение базы продуктов, блюд, клиентов и сотрудников, а также обеспечивать правильное взаимодействие этих баз. Кроме того, необходимо обеспечение всех пользователей программы нужной им информацией в удобной форме.

Целью данного курсового проекта является разработка программы для автоматизации работы кафе.

Задачами курсового проекта являются:

· описание предметной области,

· описание технологии функционирования ИС,

· физическое проектирование БД,

· разработка экранных форм ввода-вывода и отчетов.

ГЛАВА I. АНАЛИЗ ДЕЯТЕЛЬНОСТИ КАФЕ

1.1 Общие сведения, цели и задачи

Современные предприниматели всё чаще обращают свои взоры на рынок предоставления услуг в сфере общественного питания. Оно и немудрено — уровень жизни в нашей стране постепенно растёт, что позволяет всё большему количеству граждан не экономить на питании, а отдать эту услугу на откуп профессионалам. Очень многие предпочитают экономить своё время, ежедневно питаясь в кафе. Поэтому идея открыть кафе — это хороший способ начать свой бизнес.

Кафе является предприятием с полным производственным циклом, на котором выполняются все стадии технологического процесса приготовления пищи, организуются универсальные рабочие места, характерные для бесцеховой структуры предприятия. Кафе выполняет три взаимосвязанные функции: производство готовой продукции, ее реализацию и организацию потребления.

Создаваемая программа предназначена для автоматизации пункта кафе. Она ведет учет продуктов, учёт клиентов и сотрудников, формирует необходимые документы и отчеты.

В базе данных разрабатываемого программного продукта будут хранится данные о продуктах:

— код продукта;

— название;

— единица измерения.

Продукты будут составлять блюда, характеризуются следующими параметрами:

— код блюда;

— название;

Также в программе содержатся данные о клиентах:

— код клиента;

— ФИО;

— процент скидки.

Данные о сотрудниках будут характеризоваться следующими параметрами:

— код сотрудника;

— ФИО;

— должность.

Содержится информация о складах:

— код склада;

— название.

В случае, когда сотрудник принимает заказ клиента, формируется документ заказа, в котором указываются следующие данные:

— код заказа;

— текущая дата;

— сотрудник;

— клиент;

— блюда;

— количество блюд;

— цена;

— сумма.

Сотрудники благодаря данному программному продукту могут решать следующие задачи:

— регистрировать клиентов;

— добавлять и удалять данные о продуктах и блюдах;

— составлять заказ при обслуживании клиента;

— вести учет продуктов на складе;

— учитывать продажи блюд.

1.2 Организационная структура

Процесс формирования организационной структуры включает в себя формулировку целей и задач, определение состава подразделений, их ресурсное обеспечение (включая численность работающих), разработку регламентирующих процедур, документов, положений, закрепляющих и регулирующих формы, методы, процессы, которые осуществляются в организационной системе управления.

Весь этот процесс можно организовать по трем крупным стадиям:

Формирование общей структурной схемы во всех случаях имеет принципиальное значение, поскольку при этом определяются главные характеристики организации, а также направления, по которым должно быть осуществлено более углублённое проектирование, как организационной структуры, так и др. важнейших аспектов системы (способность переработки информации).

Разработка состава основных подразделений и связей между ними — заключается в том, что предусматривается реализация организационных решений не только в целом по крупным линейно-функциональным и программно — целевым блокам, но и вплоть до самостоятельных (базовых) подразделений аппарата управления, распределения конкретных задач между ними и построения внутриорганизационных связей. Под базовыми подразделениями понимаются самостоятельные структурные единицы (отделы, сектора, кухни), на которые организационно разделяются линейно-функциональные и программно-целевые подсистемы. Базовые подразделения могут иметь свою внутреннюю структуру.

Регламентация организационной структуры — предусматривает разработку количественных характеристик аппарата управления и процедур управленческой деятельности. Она включает: определение состава внутренних элементов базовых подразделений (должностей); определение проектной численности подразделений; распределение задач и работ между конкретными исполнителями; установление ответственности за их выполнение; разработку процедур выполнения управленческих работ в подразделениях; расчёты затрат на управление и показателей эффективности аппарата управления в условиях проектированной организационной структуры.

Организационная структура кафе будет выглядеть следующим образом (рис. 1.2. 1).

Рис. 1.2.1. Организационная структура кафе.

1.3 Информационная структура

Управление можно рассматривать как информационный процесс. Функционирование организации возможно исключительно при наличии информации, необходимой для выработки и реализации управленческих решений. Информация в организации образует информационные потоки.

Информационная структура кафе представлена на рисунке 1.3.1.

Рис 1.3.1. Информационная структура кафе.

1.4 Функциональная структура

Функциональная структура сложилась как неизбежный результат усложнения процесса управления. Особенность функциональной структуры заключается в том, что хотя и сохраняется единоначалие, но по отдельным функциям управления формируются специальные подразделения, работники которых обладают знаниями и навыками работы в данной области управления.

Рис. 1.4.1. Функциональная структура кафе

1.5 Информационно-техническое обеспечение

Информационно-техническое обеспечение — это просто жизненно необходимый элемент деятельности кафе. В кафе используется следующее информационно-техническое обеспечение:

1. Компьютер.

2. Фискальные регистраторы. Фискальный регистратор — это контрольно-кассовая машина, работающая только под управлением компьютера и соответствующего программного обеспечения. Фискальные регистраторы позволяют печатать на чеке наименования товара, размер предоставленной скидки, фамилию кассира и прочие данные, часто имеют авто-отрез чека. Как правило, они обладают повышенной надежностью.

В отличие от кассового аппарата, на печатающее устройство фискального регистратора, как на принтер, можно выводить любой документ. Счета клиентам можно печатать на фискальном регистраторе, при этом регистратор не фиксирует никаких сумм, а просто печатает. Фискальный регистратор обычно имеет разъём для подключения денежного ящика.

3. Считыватели магнитных карт. Принцип действия напоминает магнитофон или видеомагнитофон: магнитная головка считывает информацию, затем она декодируется — переводится в последовательность ASCII-символов.

4. Сенсорный монитор. В целом, это технология или оборудование, способное реагировать на прикосновение руки либо стилуса. Внешне такой сенсорный монитор или панель напоминают самые обычные дисплеи, но функциональное назначение имеют совершенно другое. Идеально подходит для использования на рабочем месте кассира/оператора в магазине, ресторане или фастфуде. В ряде случаев это позволяет сделать рабочее место официанта или продавца значительно просторнее.

5. Кухонные принтеры заказов. Специализированные модели чековых принтеров, предназначенных для использования в условиях кухни, с дополнительной изоляцией. Кухонные принтеры часто оснащают дополнительным звонком для сигнала о том, что пришел новый заказ.

ГЛАВА II. РАЗРАБОТКА ТЕХНИЧЕСКОГО ПРОЕКТА

2.1 Обзор аналогичных систем

Таблица 1 Сравнительная характеристика аналогичных систем

Функционал

Системы

ИНПРО: Ресторанный комплекс 8

«Трактиръ: Стандарт ПЛЮС» редакция 4. 4

1C-Рарус: Ресторан+Бар+Кафе редакция 2

АСТОР: Ресторан 2. 0

КАМИН: Общепит. Версия 3. 0

ИБЦ-Кафе

Учет продуктов

-

+

+

+

+

+

Составление блюд и калькуляция

-

+

+

+

+

+

Учет сезонного коэфициента

-

+

-

-

+

+

Индивид. права пользования системой

+

+

+

-

-

+

Доп. отчеты

+

+

+

+

+

+

Печать предчека / марок

+/+

+/-

+/+

-/-

-/+

+/+

Печать меню и прейскуранта

-

+

-

+

+

+

Безналичная оплата

-

-

+

-

-

+

Подключение доп. торгового оборудования

+

-

+

+

+

-

2.1.1 Программа ИНПРО: Ресторанный комплекс 8 [ ]

Конфигурация «ИНПРО: Ресторанный комплекс 8» предназначена для комплексной автоматизации предприятий общественного питания различного типа: ресторанов, столовых, кафе, баров, предприятий быстрого питания (fast-food).

Основные функциональные возможности программы:

-сокращение времени и ошибок при обслуживании посетителей за счет работы в интерфейсе front-office;

-взаимодействие в единой базе систем back- и front-office без необходимости специального обмена данными;

-получение данных бухгалтерского и налогового учета непосредственно из оперативных документов;

-возможность оперативного получения и анализа информации (прибыльности подразделений/номенклатуры, оборачиваемости запасов, динамики цен, объемов продаж и т. д.) для принятия управленческих решений;

-специализированный интерфейс — набор экранных форм, учитывающих специфику работы сенсорных экранов POS-систем для быстрого формирования первичных документов: заказов покупателей, выпуска продукции (приготовлению блюд, коктейлей и т. д.), оплаты (чеки);

-разграничение прав доступа по различным категориям пользователей (официант, бармен, кассир, администратор зала и управляющий);

-печать марок («команд» барменам и поварам на приготовление/подачу блюда/напитка) на соответствующих принтерах выпускающих подразделений;

-печать предварительных счетов на оплату клиентам;

-ведение продаж по нескольким организациям (при подключении к одному рабочему месту нескольких фискальных регистраторов);

-дополнительные отчеты (в т.ч. «Чистая прибыль» в разрезе выпускающих подразделений, «Отчет по изменению цен» и др.);

-дополнительные печатные формы технологических и калькуляционных карт, отражающих особенности технологии учета.

Конфигурация поддерживает работу со следующими видами торгового оборудования: фискальные регистраторы, принтеры марок, считыватели магнитных карт.

Программа «ИНПРО: Ресторанный комплекс 8» не является самостоятельной, для ее работы необходимо наличие установленной на платформе «1С: Предприятие 8. 1» типовой конфигурации «Управление производственным предприятием, редакция 1. 2». Конфигурация «ИНПРО: Ресторанный комплекс 8» является открытой и позволяет пользователю вносить изменения.

2.1.2 Программа «Трактиръ: Стандарт ПЛЮС», редакция 4. 4

«Трактиръ: Стандарт ПЛЮС» — типовое решение, входящее в семейство программных продуктов «Трактиръ» фирмы «СофтБаланс», предназначенных для автоматизации предприятий общественного питания. «Трактиръ: Стандарт ПЛЮС», редакция 4.4 — новая редакция продукта, разработанная на базе типовой конфигурации «Бухгалтерский учет, ред. 4. 4». Система «Трактиръ: Стандарт ПЛЮС» предназначена для ресторанов, кафе, бистро, столовых и других предприятиях общественного питания.

Некоторые из функций программы:

-формирование калькуляционных карточек на блюда в условиях динамического изменения закупочных, учетных и продажных цен;

-возможность использования схемы «блюдо в блюде» с неограниченным количеством уровней вложенности;

-возможность учета сезонных норм закладок продуктов в блюда;

-ведение количественно-суммового учета продуктов и блюд с контролируемым процентом наценки при назначении розничных цен на блюдо;

-возможность ведения учета продуктов и блюд на нескольких кухнях и точках реализации;

-расчет расхода сырья в соответствии с данными о реализации;

-возможность установки для одной номенклатурной единицы разных цен для различных мест реализации и единиц измерения;

-возможность свободного перемещения продуктов на кухни для производства блюда, либо в розничную продажу на точки реализации;

-формирование меню для зала и прейскуранта барной продукции;

-складской учет наличия и движения продуктов в разрезе номенклатуры и мест хранения;

-учет служебного питания по каждому сотруднику;

-отчеты в различных разрезах.

Возможности конфигурации по работе с торговым оборудованием: поддержка работы с кассовыми аппаратами в режиме «Off-Line», программируемыми ресторанными клавиатурами и сканерами штриховых кодов, поддержка обмена с фронт-офисной системой «Трактиръ: Front-Office» по стандарту CommerceML; автоматическое формирование документов «Акт о реализации изделий кухни» (для блюд), «Розничная реализации» (для товаров), «Акт оказания услуг» (для услуг) на основании данных о продажах из кассовых аппаратов и/или системы «Трактиръ: Front-Office».

Перечисленные возможности позволяют:

-значительно ускорить получение информации о проданных за смену блюдах, товарах и оказанных услугах;

-предоставить посетителям информативные чеки с указанием наименования блюда/товара/услуги, их количества, цены и стоимости;

-обеспечить быстрый ввод товаров и блюд в чек посредством сканеров штрих-кодов;

-сократить пересортицу;

-уменьшить количество инвентаризаций и время их проведения;

-обеспечить дополнительный контроль кассиров и официантов;

Особенности конфигурации:

-отсутствие жесткого закрепления последовательности ввода документов позволяет пользователям создавать свои технологические схемы учета на предприятии;

-выполнение калькуляционных карт в виде документов, а не справочников, делает процесс расчета себестоимости более технологичным, т. е. упрощает ввод данных и облегчает работу с ними;

-возможность создания нескольких калькуляционных карт для одного блюда;

-«Корректировка калькуляции» позволяет учитывать и контролировать замену компонентов блюда;

-оптимальное изменение плана счетов позволяет осуществить простой переход с типовой конфигурации на использование системы «Трактиръ: Стандарт ПЛЮС».

2.1.3 1C-Рарус: Ресторан+Бар+Кафе, редакция 2

Конфигурация разработана на основе базовых объектов системы 1С: Предприятие, может использоваться с компонентами «Бухгалтерский учет», «Оперативный учет», «Расчет», и представляет собой готовое решение для автоматизации процессов розничной продажи на предприятиях общественного питания с использованием торгового оборудования.

Конфигурация может использоваться как самостоятельно, так и совместно с типовым решением «1С-Рарус: Общепит» редакции 6 версий «Стандарт» и «Проф», при этом настоящая конфигурация будет выполнять роль Front-Office, в то время как ТР «1С-Рарус: Общепит» будет выполнять роль Back-Office.

Типовое решение позволяет создать специализированные персональные рабочие места следующих работников: администратора автоматизированной системы управления торговым процессом, менеджера смены, кассира, официанта, бармена.

Для создания автоматизированных рабочих мест в типовом решении применяются специализированные эргономичные интерфейсы, в т. ч. с использованием дисплеев Touch-Screen, позволяющие реализовать все необходимые действия в соответствии с функциями, выполняемыми сотрудниками предприятия:

-набор заказов от клиентов с различных столиков зала ресторана или с барной стойки. Ввод заказов осуществляется с использованием номенклатурных позиций и их свойств, которые также могут менять розничную стоимость блюд. Могут также использоваться отчерки заказов для определения очередности приготовления блюд. При вводе заказа сохраняется «история» изменения его состава;

-печать заказов клиентов на кухонных принтерах с автоматическим определением места приготовления;

-ввод дисконтных карт и назначение различных видов скидок;

-печать пречеков;

-прием наличной и безналичной оплаты, в т. ч. с автоматической авторизацией платежных карт;

-пробитие чека по заказу на фискальном регистраторе. Выполнение возвратов по пробитым чекам, выполнение быстрых продаж с пробитием чека без создания заказа;

-полный или частичный перенос товарного состава заказа между столами и официантами;

-закрытие кассовой смены с созданием дневных отчетов о продажах в различных аналитических разрезах с сохранением архива пробитых чеков;

-списание неоплаченных позиций заказов;

-получение отчетности по результатам реализации/списания товаров;

-контроль состояния заказов в залах ресторана;

-гибкая настройка конфигурации рабочих мест, прав пользователей и торгового оборудования;

Типовое решение позволяет использовать различное торговое оборудование следующих классов: фискальные регистраторы, авторизаторы безналичных платежей, программируемые клавиатуры, touch-Screen мониторы (сенсорные дисплеи), дисплеи покупателей, сканеры штрих-кодов и ридеры магнитных карт, кухонные принтеры заказов.

2.1.4 Программа АСТОР: Ресторан 2. 0

Конфигурация «АСТОР: Ресторан v.2. 0» разработана на основе компоненты «Оперативный учет» системы 1С: Предприятие и представляет собой типовое решение для комплексной автоматизации кафе, баров, ресторанов и т. п. Конфигурация позволяет вести в одной информационной базе учет от имени нескольких организаций, а также вести одновременно два вида учета торговой деятельности: управленческий и финансовый.

Учет работы предприятия общественного питания поддерживает все операции, связанные с закупкой, хранением ингредиентов, полуфабрикатов и готовых блюд, переработкой полуфабрикатов, приготовлением и реализацией блюд и, связанными с этими операциями, взаиморасчетами с покупателями и поставщиками.

Функционал конфигурации, учитывающий особенности учета производства и реализации продукции на предприятиях общественного питания: составление блюд и калькуляций; печать технологических карт; наличие план-меню и автоматического расчета заказа кладовщику; производство готовой продукции и полуфабрикатов; продажа блюд по марочному отчету; наличие сличительной ведомости.

Общие сведения о конфигурации: автоматическое списание себестоимости товаров по одному из методов (по среднему, LIFO, FIFO); учет товаров, взятых и отданных на реализацию; операции с товарами по нескольким единицам измерения; учет взаиморасчетов с поставщиками и покупателями; многовалютный учет торговых операций, выписка торговых документов в любой валюте.

Отчеты — остатки товаров (блюд), движение товаров (блюд), продажи товаров (блюд), взаиморасчеты с поставщиками и покупателями, позволяют быстро получать информацию о хозяйственной деятельности предприятия.

Для связи с бухгалтерским учетом предназначена обработка по формированию (выгрузке) проводок.

Конфигурация «АСТОР: Ресторан v.2. 0» содержит интерфейс для обмена данными с ресторанной системой R-Keeper v. 6, которая предназначена для организации высокотехнологичного кассового обслуживания ресторанов с любой формой оплаты и может работать с несколькими кассовыми аппаратами (станциями). R-Keeper поддерживает 4 вида станций: менеджер, бармен, официант и кассир. Все данные о торговых операциях со станций системы R-Keeper через интерфейс автоматически попадают в базу данных «АСТОР: Ресторан v. 2. 0»

2.1.5 Программа КАМИН: Общепит. Версия 3. 0

Конфигурация «КАМИН: Общепит. Версия 3. 0» предназначена для автоматизации ресторанного бизнеса и предприятий общественного питания: ресторанов, столовых, кафе, баров, буфетов, предприятий быстрого питания, в том числе для небольших производственных цехов по производству полуфабрикатов и готовых изделий. Решение обеспечивает автоматизацию бэк-офиса предприятий.

Конфигурация «КАМИН: Общепит. Версия 3. 0» позволяет:

-вести многофирменный учет, то есть вести в одной информационной базе данные по нескольким учреждениям;

-учитывать продукты питания в разных упаковках и фасовках;

-вести учет поступления, списания, выпуска и реализации продукции и продуктов питания;

-вести списки рецептур и технологии приготовления блюд согласно сборникам рецептур или технико-технологическим картам;

-учитывать сезонные коэффициенты при расчете расхода сырья, выхода полуфабрикатов и готовых изделий;

-формировать калькуляционные карточки блюд за любой период;

-вести список ингредиентов блюд, включающий как продукты, так и другие блюда — с любой степенью вложенности;

-вести учет взаимозаменяемости продуктов в производстве (аналоги ингредиентов);

-формировать документы и специализированные отчеты (план-меню, меню, прайс-лист, марочный отчет, расчет к заказ-наряду на изготовление изделий, требование-накладная, товарный отчет и другие).

Конфигурация является оригинальной. При разработке конфигурации использовались объекты инструментария «Библиотека стандартных подсистем» фирмы «1С».

Конфигурация предназначена для работы в режиме управляемого приложения. Для работы программы необходима установка платформа «1С: Предприятие 8. 2». Исходный код конфигурации открыт для изменений.

2.1.6 Программа ИБЦ-Кафе

Конфигурация «ИБЦ-КАФЕ (Калькуляционный учет + Рабочее место официанта) 3. 3» предназначена для комплексной или частичной автоматизации предприятий общественного питания, которая представляет интерес как для крупных современных предприятий ресторанного бизнеса, так и для небольших уютных кафе.

«ИБЦ-КАФЕ» является полностью оригинальной конфигурацией и состоит из двух условных компонент: «Калькуляционный учет» и «Рабочее место официанта».

Компонента «Калькуляционный учет» позволяет вести учет поступлений и реализации как блюд, так и продуктов (вино-водочные изделия, сигареты и т. д.) через различные подразделения фирмы.

Конфигурация имеет обширные возможности по составлению калькуляций блюд (ведение неограниченного числа карточек для каждого блюда, режим автоматического пересчета калькуляционных карточек при изменении цен продуктов, неограниченная вложенность при внесении в калькуляционную карточку полуфабрикатов или других блюд, печать, тестирование, поиски ссылок на продукты и др.).

«Калькуляционный учет» содержит набор документов, автоматизирующих следующие отделы учета:

-приход, расход и передача между подразделениями различных видов товарно-материальных ценностей;

-широчайшие возможности по инвентаризации, пересортице и переоценке товаров;

-приготовления блюд и списания продуктов и полуфабрикатов, требующихся для их приготовления на основании калькуляционных карточек в соответствии с наличием продуктов, их допустимых замен и сезонных коэффициентов;

-расчета стоимости банкетов и количества ингредиентов, требующихся для их приготовления;

-розничной продажи товаров по различным видам оплаты и категориям цен;

-формирования печатных форм меню и прейскурантов;

-учет операций по банку и кассе;

-учет расчетов с подотчетными лицами и другие.

«Калькуляционный учет» включает наборы специализированных отчетов по конкретным разделам учета (остаткам и движениям продуктов и блюд, взаиморасчетам с поставщиками и покупателями, реализации и фактической прибыли предприятия, анализу минимальных запасов) и стандартные отчеты, позволяющие получать данные бухгалтерского учета в различных разрезах по любым счетам и любым объектам аналитики.

Компонента «Рабочее место официанта» системы предназначена для автоматизации работы официантов. Позволяет ускорить и облегчить работу официантов, а также осуществлять контроль их действий в любой момент времени. «Рабочее место официанта» включает:

-настройку индивидуальных прав пользования системой для каждого официанта;

-строгую идентификацию каждого официанта при входе в систему;

-ввод и сохранение заказа с возможностью дальнейшего дополнения (дозаказа), используя меню или перечень наиболее часто заказываемых позиций;

-быструю печать заявок-требований («отписок») на удаленные принтеры в подразделения приготовления (кухня, бар) с возможностью указания примечаний к блюдам и конкретного времени к выдаче;

-указание скидок и наценок различными способами;

-указание вида оплаты и, если необходимо, стола, количества гостей и вольного примечания к заказу;

-печать гостевого счета для клиента (в т.ч. на фирменном бланке заведения);

-осуществление полного контроля работы персонала: формирование реестра счетов, отчетов по конкретным официантам, просмотр и контроль их «подозрительных» действий;

-обработки для связи с компонентой «Калькуляционный учет»: автоматическое создание «Актов реализации» на основе выписанных «Заявок».

Конфигурация «ИБЦ-КАФЕ (Калькуляционный учет + Рабочее место официанта) 3. 3» не является самостоятельной программой и предназначена для использования с компонентой «Бухгалтерский учет» системы программ «1С: Предприятие 7. 7».

2.1.7 Программа «Guscom POS»

Программный комплекс Guscom — современное, стабильное, гибкое программное обеспечение, предназначенное для ресторанов, баров, фаст-фуд. В настоящее время программный комплекс Guscom установлен в свыше 1000 предприятий общественного питания Европы, с 2004 года в Белоруссии, а с 2006 года и в России. В их числе есть и сетевые предприятия общепита (сеть кофеен «Кофе Хауз»), гостиничного бизнеса и маленькие кафе и рестораны с несколькими столиками.

Важная особенность комплекса — наличие возможностей как управленческого так и бухгалтерского учета, что позволяет получить достоверную информацию на текущий момент времени. На основе такой информации можно принимать решения и контролировать ситуацию. Управление системой общепита (сети ресторанов, кафе, фаст-фуд) — это управление ресурсами: товаром, финансами, персоналом и клиентами. Применение промышленной СУБД SAP DB не позволяет вносить данные «задним числом». Любые исправления и дополнения заносятся в журнал коррекций, а некоторые изменения, благодаря настройкам, можно как ограничить, так и запретить совсем.

Мультиплатформенность комплекса позволяет клиенту в ресторане выбирать наиболее приемлемую и подходящую ОС. В зависимости от IT-инфраструктуры предприятия все модули Guscom могут использоваться как с OS Windows (NT, 2000, 2003, XP), так и с OS Linux (начиная с версии ядра 2. 4).

Guscom обладает следующими уникальными возможностями:

On-line настройка (Remove desktop) — возможность удаленной настройки и мониторинга самого комплекса;

On-line отчеты — возможность при подключении к Интернету владеть текущей ситуацией и просматривать отчёты по любому подразделению и сотруднику за любой период;

On-line регистрация скидки постоянного клиента для всех ресторанов сети. Клиент, придя в другой ресторан сети, получает положенную ему скидку.

Программный комплекс Guscom имеет очень простой, графический, настраиваемый интерфейс, что позволяет настроить экран по желанию пользователя, вставить фотографии блюд и товаров, а также графический план столов с индикацией их состояния. Гибкость программы позволяет использовать ее огромные возможности в соответствии с потребностью и квалификацией пользователя.

Комплекс состоит из нескольких компонент:

— Guscom. POS — Программный комплекс, включающий в себя весь набор функций для работы персонала;

— Guscom. CR — Утилита подключения фискального регистратора СПАРК, успешно зарекомендовавшего себя во многих системах общепита и торговли;

— Guscom. NETVIEWER — система on-line контроля ресторана. Позволяет при подключении к Интернету владеть текущей ситуацией и просматривать отчёты по любому подразделению и сотруднику за любой период;

— Guscom. TRS — Модуль учёта контроля рабочего времени сотрудников. Позволяет, используя имеющиеся считыватели магнитных карт и магнитные карты идентификации сотрудника, вести учёт рабочего времени, контролируя приход, уход, а также обеденные перерывы и отсутствие по причинам, конфигурируемым администрацией заведения. Предоставляется расширенный отчёт по использованию рабочего времени каждого сотрудника;

— Guscom. Club — дополнительный программный модуль, созданный специально для клубов и дискотек. Он позволяет работать с клиентскими картами и/или централизованным инкассо.

— Guscom. MMS — Приложение, позволяющее получать доступ к различным модулям ПО Guscom: отчётности, системе управления рабочим временем, клубной системе, вводу постоянных посетителей.

— Guscom. Mobile — Мобильный терминал, заменяющий традиционный блокнот официанта, обеспечивая мгновенное попадание введённого заказа в систему, а также последующее его сопровождение.

2.2 Эскиз технического задания

Назначение информационной системы — автоматизировать процесс работы кафе

Целью разработки информационной системы является облегчение процесса учета поступления и использования продуктов, а так же возможность формирования печатных форм документов, отчётов и других объектов конфигурации.

Необходимо разработать систему учёта, которая включает в себя:

1. Возможность учета доходов кафе;

2. Формирование отчетов;

В системе учёта должны быть реализованы следующие функции:

1. Ведение базы данных продуктов, блюд, клиентов, сотрудников;

2. Возможность документального отражения в учётной программе всех этапов движения услуг;

3. Учёт денежных средств;

4. Формирование текущих отчетов.

Для работы с данной информационной системой необходимо наличие на рабочей станции платформы «1С: Предприятия 8. 1». Визуальная среда разработки является неотъемлемой частью пакета программ «1С: Предприятие». (Под визуальной средой понимается Конфигуратор задач). Платформой предоставляется фиксированный набор базовых классов, ориентированных на решение типовых задач прикладной области.

Общие требования к техническому обеспечению:

1. Компьютеры в соответствии с системными требованиями платформы 1С: Предприятие 8.1. ;

2. Устройство вывода на печать.

2.3 Логическая модель информационной системы

Логический уровень — это абстрактный взгляд на данные, на нем данные представляют так, как выглядят в реальном мире. Объекты модели, представленные на логическом уровне, называются сущностями и атрибутами. Логическая модель данных может быть построена на основе другой логической модели, например, на основе модели процессов. Логическая модель данных является универсальной. Логическая модель данных описывает факты и объекты, подлежащие регистрации в ней. Устанавливаются связи между сущностями, определяются атрибуты и проводятся нормализация данных.

Рис. 2.3.1. Логическая модель информационной системы кафе

2.4 Физическая модель

Дерево метаданных «Кафе»

Перечисления

Единица измерения

Килограмм

Литр

Штука

Справочники

Продукты

Код

число 10

Название

строка 50

Единицы измерения

перечисление

Количество

число 10

Сотрудники

Код

число 10

ФИО

строка 150

Должность

строка 50

Клиенты

Код

число 10

ФИО

строка 150

Процент скидки

число 10

Склады

Код

число 10

Название

строка 50

Блюда

Код

число 10

Название

строка 50

Документы

Приходная накладная (+ Регистр накопления Остатки продуктов)

Склад

Справочник. Ссылка. Склад

Сотрудник

Справочник. Ссылка. Сотрудники

Табличная часть

Продукты

Справочник. Ссылка. Продукты

Количество

число 10

Цена

число 10

Сумма

число 10

Списание (- Регистр накопления Остатки продуктов)

Склад

Справочник. Ссылка. Склад

Сотрудник

Справочник. Ссылка. Сотрудники

Табличная часть

Продукты

Справочник. Ссылка. Продукты

Количество

число 10

Цена

число 10

Сумма

число 10

Заказ (- Регистр накопления Остатки продуктов)

Склад

Справочник. Ссылка. Склад

Сотрудник

Справочник. Ссылка. Сотрудники

Клиент

Справочник. Ссылка. Клиенты

Табличная часть

Блюдо

Справочник. Ссылка. Блюдо

Количество

число 10

Цена

число 10

Сумма

число 10

КалькКарта (Регистр сведений Цена поступления)

Блюдо

Справочник. Ссылка. Блюдо

Табличная часть

Продукт

Справочник. Ссылка. Блюдо

Количество

число 10

Цена

число 10

Сумма

число 10

Отчеты

Остатки продуктов

Формирует данные об остатках продуктов на складе

Прайс

Формирует данные о ценах блюд

Продажи

Формирует данные о количествах продаваемых блюд

Выручка

Формирует данные о выручке с продаж

Регистры накопления

Продажи

(+ Заказ)

Измерения

Блюдо

Справочник. Ссылка. Блюдо

Ресурсы

Количество

число 10

Выручка

число 10

Списание (- Регистр накопления Остатки продуктов)

Склад

Справочник. Ссылка. Склад

МОЛ

Справочник. Ссылка. Сотрудники

Табличная часть

Продукты

Справочник Ссылка. Продукты

Количество

число 10,3

Цена

число 7,2

Сумма

число 10,2

Заказ (- Регистр накопления Остатки продуктов)

Склад

Справочник Ссылка. Склад

Сотрудник

Справочник Ссылка. Сотрудники

Клиент

Справочник Ссылка. Клиенты

Табличная часть

Блюдо

Справочник Ссылка. Блюда

Количество

число 2

Цена

число 7,2

Сумма

число 10,2

КалькКарта

Блюдо

Справочник Ссылка. Блюда

Количество

Число 2

Наценка

Число 7,2

Табличная часть

Продукт

Справочник Ссылка. Продукты

Количество

число 10,3

Цена

число 7,2

Сумма

число 10,2

Себестоимость

Число 7,2

Отчеты

Остатки продуктов

Формирует данные об остатках продуктов на складе

Прайс

Формирует данные о ценах блюд

Продажи

Формирует данные о количествах продаваемых блюд

Выручка

Формирует данные о выручке с продаж

Регистры накопления

Продажи

(+ Заказ)

Измерения

Блюдо

Справочник. Ссылка. Блюда

Ресурсы

Количество

число 10

Выручка

число 10

Остатки продуктов (+ Приходная накладная; - Списание, Заказ)

Измерения

Продукты

Справочник. Ссылка. Продукты

Склад

Справочник. Ссылка. Склад

Ресурсы

Количество

число 10

Разница (КальКарта, Прайс)

Измерения

Блюдо

Справочник Ссылка. Блюда

Измерения

Себестоимость

Число 7,2

Цена

Число 7,2

Разница

Число 7,2

Регистр сведений

Прайс (Заказ)

Измерения

Блюдо

Справочник Ссылка. Блюда

Ресурсы

Цена

число 7,2

КалькКарта (КалькКарта)

Измерения

Блюдо

Справочник Ссылка. Блюда

Ресурсы

Себестоимость

число 7,2

Рис. 2.4.1. Конфигурация системы

программа информационный информационный модуль

ГЛАВА II. РЕАЛИЗАЦИЯ ПРОЕКТА

3.1 Разработка экранных форм

Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа «Справочник».

Механизм поддержки справочников позволяет спроектировать и поддерживать самые различные справочники. На этапе конфигурирования можно описать, какими свойствами обладает каждый конкретный справочник. К настраиваемым свойствам относятся, например, длина и тип кода, количество уровней, поддержка уникальности кодов, набор реквизитов справочника.

Помимо кода и наименования, механизм работы со справочниками позволяет создавать набор реквизитов для хранения любой дополнительной информации об элементе справочника. Для реквизитов справочника возможно указание типа «Периодический» для отслеживания истории изменения значений реквизитов.

Для каждого справочника может быть задано несколько форм просмотра и редактирования.

Справочник «Продукты» предназначен для хранения информации о продуктах (рис. 3.1. 1). Справочник «Меню» предназначен для хранения информации о блюдах (рис. 3.1.2.). Справочник «Сотрудники» позволяет хранить информацию о сотрудниках (рис. 3.1. 3), аналогичный справочник «Клиенты» служит хранилищем для информации о клиентах. В справочнике «Склад» можно указать на каком именно складе хранятся продукты (рис. 3.1.4.).

Рис. 3.1.1 Форма справочника «Продукты»

Рис. 3.1.2 Форма справочника «Меню»

Рис. 3.1.2 Форма справочника «Сотрудники»

Рис. 3.1.2 Форма справочника «Склады»

3.2 Разработка модулей для прикладных решений

Документ -- одно из основных понятий системы «1С: Предприятие». При помощи документов организуется ввод в систему информации о совершаемых хозяйственных действиях, ее просмотр и, если необходимо, корректировка.

В большинстве своем документы, которые создаются в процессе настройки конфигурации, являются электронными аналогами стандартных бумажных документов, однако, использование этого типа данных может выходить далеко за рамки простой фиксации информации о хозяйственных операциях.

В конфигураторе создается, строго говоря, не сам документ, а средство ввода документа в компьютер -- шаблон документа. Каждый создаваемый в конфигураторе документ является описанием множества документов одного вида. Например, созданный в конфигураторе документ «Накладная» при работе с системой 1С: Предприятие позволит формировать накладные, которые будут иметь разное содержание, но одинаковый набор реквизитов, одинаковую логику поведения и так далее.

В информационной системе представлены следующие документы: Приходная накладная, Списание, Калькуляционная карта и Заказ.

Документ «Приходная накладная» предназначен для ввода закупленных продуктов (рис. 3.2.1.). Данный документ двигает регистр накопления «Остатки продуктов», вид движения — приход. Аналогично выглядит документ списание, который позволяет нам списывать продукты в связи с порчей и др. (рис. 3.2.2.). Двигает регистр накопления «Остатки продуктов», вид движения — расход. Процедура обработки проведения у данных документов будут похожи, имея различия только в виде движения.

Рис. 3.2.1. Форма документа «Приходная накладная»

Рис. 3.2.2. Форма документа «Списание»

Документ «Списание», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаПродукты Из Продукты Цикл

Движение = Движения. ОстаткиПродуктов. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Продукты = ТекСтрокаПродукты. Продукты;

Движение. Склад = Склад;

Движение. Количество = ТекСтрокаПродукты. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «КалькКарта» предназначен для введения информации о составе блюд (рис. 3.2.3.), позволяет подсчитывать себестоимость блюда. Документ «Заказ» позволяет нам оформлять заказ клиента, подсчитывать сумму заказа и печатать чек (рис. 3.2.5.). Данный документ двигает регистр накопления «Остатка продуктов», с запросом данных из документа «КалькКарта». Вид движения — расход. Так же двигает, документ двигает регистр накопления «Продажи».

Рис. 3.2.3. Форма документа «КалькКарта»

Рис. 3.2.4. Форма документа «Заказ»

Документ «Заказ», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

Запрос = Новый Запрос;

Запрос. Текст = «ВЫБРАТЬ

|ЗаказЗаказ. Блюдо,

|ЗаказЗаказ. Количество КАК КоличествоБлюда,

|КалькКартаПродукты. Продукт,

|КалькКартаПродукты. Количество КАК КоличествоПродукта,

|ОстаткиПродуктовОстатки. Склад,

|ОстаткиПродуктовОстатки. КоличествоОстаток КАК ОстатокПродукта,

|КалькКартаПродукты. Продукт. Наименование

|ИЗ

|Документ. Заказ. Заказ КАК ЗаказЗаказ

|ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ. КалькКарта. Продукты КАК КалькКартаПродукты

|ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления. ОстаткиПродуктов. Остатки (&Период,) КАК ОстаткиПродуктовОстатки

|ПО КалькКартаПродукты. Продукт = ОстаткиПродуктовОстатки. Продукты

|ПО ЗаказЗаказ. Блюдо = КалькКартаПродукты. Ссылка. Блюдо

|ГДЕ

|ЗаказЗаказ. Ссылка = & Ссылка";

Запрос. УстановитьПараметр («Ссылка», Ссылка);

Если Режим = РежимПроведенияДокумента. Оперативный Тогда

Запрос. УстановитьПараметр («Период», Неопределено);

Иначе

Запрос. УстановитьПараметр («Период», Дата);

КонецЕсли;

Выборка = Запрос. Выполнить (). Выбрать ();

Пока выборка. Следующий () цикл

КоличествоСписать = Выборка. КоличествоБлюда * Выборка. КоличествоПродукта;

ОстатокПродукта = ?(Выборка. ОстатокПродукта = Null, 0, Выборка. ОстатокПродукта);

Если (КоличествоСписать <= ОстатокПродукта) Тогда

Если Не Отказ Тогда

Движение = Движения. ОстаткиПродуктов. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Склад = Выборка. Склад;

Движение. Продукты = Выборка. Продукт;

Движение. Количество = КоличествоСписать;

КонецЕсли;

Иначе

Отказ = Истина;

Сообщить («Не хватает продукта «+ Выборка. ПродуктНаименование + «в количестве «+ Строка (КоличествоСписать — ОстатокПродукта));

КонецЕсли;

КонецЦикла;

Если Не Отказ Тогда

Для Каждого ТекСтрокаЗаказ Из Заказ Цикл

// регистр Продажи

Движение = Движения. Продажи. Добавить ();

Движение. Период = Дата;

Движение. Блюдо = ТекСтрокаЗаказ. Блюдо;

Движение. Количество = ТекСтрокаЗаказ. Количество;

Движение. Выручка = ТекСтрокаЗаказ. Сумма;

КонецЦикла;

КонецЕсли;

КонецПроцедуры

Цены продуктов в документ «КалькКарта» заполняются из регистра сведений «Цены поступления», цены блюд в документ «Заказ» заполняются из регистра сведений «Цены блюд».

3.3 Разработка отчетов

Для простоты работы с имеющейся информацией, в информационной системе были созданы следующие отчеты: Остатки продуктов, Продажи, Прайс, Выручка. Отчет «Остатки продуктов» содержит сведенья об остатках продуктов на складе (рис. 3.3.1.). «Прайс» содержит блюда и цены на них (рис. 3.3.2.). «Выручка» позволяет получить полную информацию о поступлении денежных средств в кассу (рис. 3.3.4.).

Рис. 3.3.1. Отчет «Остатки продуктов»

Рис. 3.3.3. Отчет «Выручка»

ЗАКЛЮЧЕНИЕ

Неоспоримым преимуществом автоматизированных систем управления является то, что они не требуют никаких дополнительных вложений. Автоматизированные системы управления достаточно легко поддаются необходимым корректировкам в соответствии с требованиями рабочего процесса предприятия.

В результате выполнения данного курсового проекта все поставленные цели и задачи были выполнены. Были описаны технологии функционирования ИС, выполнено физическое проектирование БД, разработаны экранные форм ввода-вывода и отчеты, разработаны функциональные модули.

В результате проделанной работы было разработано приложение для работы кафе. Оно автоматизирует доступ к базе данных и оптимизирует работу персонала.

Информационная система разработана на платформе «1С: Предприятие» версии 8.1. Данный выбор обусловлен широкими возможностями по ведению учета хозяйственных операций, предоставляемыми системой.

СПИСОК ИСПОЛЬЗОВАННОЙ ЛИТЕРАТУРЫ

1. Белоусов П. Н., Островерх А. Д. 1С: Предприятие: от 8.0 к 8. 1[Текст] / П. Н. Белоусов, А. Д. Островерх. — Питер: «1С-Паблишинг», 2008. — 577 стр.

2. Вендров А. М. Проектирование программного обеспечения экономических информационных систем: Учебник для студентов, обучающихся по специальности «Прикладная информатика» и «Прикладная математика и информатика [Текст] / А. М. Вендров. — М.: Финансы и статистика, 2001. — 221 с.

3. Габец А. П., Гончаров Д. И. 1С: Предприятие 8.1. Простые примеры разработки [Текст] / А. П. Габец, Д. И. Гончаров. — Питер: «1С-Паблишинг», 2009. — 383 стр.

4. Информационные системы в экономике в вопросах и ответах: Учебн. пособие. — М.: Т К Велби, Издательство «Проспект», 2004. — 280 с.

5. Маклаков С. В. BPwin и ERwin. CASE — средства разработки информационных систем. Учебное пособие [Текст] / С. В. Маклаков. -Москва: Диалог — МИФИ, 1999. — 256с.

6. Радченко М. А. 1С: Предприятие 8.1. Практическое пособие разработчика. Примеры и типовые приемы [Текст] / М. А. Радченко. — Питер: «1С-Паблишинг», 2009. — 512 стр.

7. Хрусталева Е. Ю. Разработка сложных отчетов в 1С: Предприятии 8 Система компоновки данных [Текст] / Е. Ю. Хрусталева — Питер: «1С-Паблишинг», 2009. — 489 стр.

8. Борисов В. В. Компьютерная поддержка сложных организационно- технических систем. [Текст]:/ В. В Борисов, И. А. Бычков, А. В. Дементьев. — Горячая линия — Телеком, 2002 -300с.

9. Гайдамакин Н. А. Автоматизированные информационные системы, базы и банки данных. ввод. курс [Текст]: учеб. пособие для вузов ./ Н. А. Гайдамакин — М.: Гелиос АРВ, 2002. — 101 с.

10. Баженова И. Ю. Основы проектирования приложений баз данных. [Текст]: учеб. пособие ./ И. Ю. Баженова — М.: Интернет-Ун-т Информ Технологий БИНОМ. Лаб. знаний, 2006. — 252 с.

11. Сайт компании 1с [Электронный ресурс]

ПРИЛОЖЕНИЕ

Общий модуль «Работа с ценой»:

Функция ЦенаПоступления (АктуальнаяДата, ЭлементПродукт) Экспорт

// Создать вспомогательный объект Отбор

Отбор = Новый Структура («Продукт», ЭлементПродукт);

// Получить актуальные значения ресурсов регистра

ЗначенияРесурсов = РегистрыСведений. ЦеныПостПродуктов. ПолучитьПоследнее (АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов. Цена;

КонецФункции

Общий модуль «Работа со справочниками»:

Функция РозничнаяЦена (АктуальнаяДата, ЭлементБлюдо) Экспорт

// Создать вспомогательный объект Отбор

Отбор = Новый Структура («Блюдо», ЭлементБлюдо);

// Получить актуальные значения ресурсов регистра

ЗначенияРесурсов = РегистрыСведений. ЦеныБлюд. ПолучитьПоследнее (АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов. Цена;

КонецФункции

Общий модуль «Работа с документами»:

Процедура РассчитатьСумму (СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти. Сумма = СтрокаТабличнойЧасти. Количество * СтрокаТабличнойЧасти. Цена;

КонецПроцедуры

Документ «Приходная накладная», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаПродукты Из Продукты Цикл

// регистр ОстаткиПродуктов Приход

Движение = Движения. ОстаткиПродуктов. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Продукты = ТекСтрокаПродукты. Продукты;

Движение. Склад = Склад;

Движение. Количество = ТекСтрокаПродукты. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Приходная накладная», модуль формы:

Процедура ПродуктыКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура ПродуктыЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Документ «Списание», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Для Каждого ТекСтрокаПродукты Из Продукты Цикл

// регистр ОстаткиПродуктов Расход

Движение = Движения. ОстаткиПродуктов. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Продукты = ТекСтрокаПродукты. Продукты;

Движение. Склад = Склад;

Движение. Количество = ТекСтрокаПродукты. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Списание», модуль формы:

Процедура ПродуктыКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура ПродуктыЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Документ «КалькКарта», модуль формы:

Процедура ПродуктыКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура ПродуктыЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура ПродуктыПродуктПриИзменении (Элемент)

// Получить текущую строку табличной части

СтрокаТабличнойЧасти = ЭлементыФормы. Продукты. ТекущиеДанные;

// Установить цену

СтрокаТабличнойЧасти. Цена = РаботаСЦеной. ЦенаПоступления (Дата, Элемент. Значение);

// Пересчитать сумму строки

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Документ «Заказ», модуль формы:

Процедура ЗаказКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Заказ. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

// Вставить содержимое обработчика.

КонецПроцедуры

Процедура ЗаказЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы. Заказ. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура ЗаказБлюдоПриИзменении (Элемент)

// Получить текущую строку табличной части

СтрокаТабличнойЧасти = ЭлементыФормы. Заказ. ТекущиеДанные;

// Установить цену

СтрокаТабличнойЧасти. Цена=РаботаСоСправочниками. РозничнаяЦена (Дата, Элемент. Значение);

// Пересчитать сумму строки

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

Процедура Печать (Элемент)

//{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ (Печать)

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

ТабДок = Новый ТабличныйДокумент;

Макет = Документы. Заказ. ПолучитьМакет («Печать»);

// Заголовок

Область = Макет. ПолучитьОбласть («Заголовок»);

ТабДок. Вывести (Область);

// Шапка

Шапка = Макет. ПолучитьОбласть («Шапка»);

Шапка. Параметры. Заполнить (ЭтотОбъект);

ТабДок. Вывести (Шапка);

// Заказ

Область = Макет. ПолучитьОбласть («ЗаказШапка»);

ТабДок. Вывести (Область);

ОбластьЗаказ = Макет. ПолучитьОбласть («Заказ»);

Для Каждого ТекСтрокаЗаказ Из Заказ Цикл

ОбластьЗаказ. Параметры. Заполнить (ТекСтрокаЗаказ);

ТабДок. Вывести (ОбластьЗаказ);

КонецЦикла;

Область = Макет. ПолучитьОбласть («Всего»);

Область. Параметры. ВсегоПоДокументу = Заказ. Итог («Сумма»);

ТабДок. Вывести (Область);

ТабДок. ОтображатьСетку = Ложь;

ТабДок. Защита = Ложь;

ТабДок. ТолькоПросмотр = Ложь;

ТабДок. ОтображатьЗаголовки = Ложь;

ТабДок. Показать ();

//}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ

КонецПроцедуры

Заказ Форма печати

ПоказатьСвернуть
Заполнить форму текущей работой