Автоматизация бухгалтерского учета на предприятии

Тип работы:
Курсовая
Предмет:
Программирование


Узнать стоимость

Детальная информация о работе

Выдержка из работы

Содержание

Введение

Глава 1. Планы видов характеристик и регистры расчета

Глава 2. Решение задачи по оперативному учету

Заключение

Список литературы

Введение

Проблемы повышения прибыльности предприятия, эффективности работы персонала, создание оптимальной структуры управления волнуют любого руководителя. Ему приходится принимать решения в условиях неопределенности и риска, что вынуждает его постоянно держать под контролем различные аспекты финансово — хозяйственной деятельности. Эта деятельность отражена в большом количестве документов, содержащих разнородную информацию. Грамотно обработанная и систематизированная она является в определенной степени гарантией эффективного управления производством. Напротив, отсутствие достоверных данных может привести к неверному управленческому решению и, как следствие, к серьезным убыткам.

Бухгалтерский учет — строго регламентированный процесс, который сравнительно легко поддается описанию и определению. Бухгалтерский учет, непрерывное фиксирование и анализ данных, позволяющих получить количественную экономическую информацию о деятельности предпринимательских и иных организаций. Для исполнения своих задач — бухгалтерский учет использует установленные бухгалтерские методы, а также система строго регламентированных законом измерения и оценок объектов бухгалтерского учета. Документирование всех хозяйственных операций осуществляется уже установленными законными методами, используя определенные законом образцы и формы первичных документов.

Внедрение бухгалтерских пакетов и программ позволяет автоматизировать не только бухгалтерский учет, но и навести порядок в складском учете, в снабжении и реализации продукции, товаров, отслеживать договоры, быстрее рассчитывать заработную плату, своевременно сдавать отчетность.

Из-за небрежности в бухгалтерском учете предприятие может сильно пострадать или даже потерпеть крах. Примеров тому и очень много, причем часто страдают предприятия, стремящиеся работать честно. Страдают из-за небрежного ведения внутренней бухгалтерии предприятия. Страдают также из-за незнания и соответственно невыполнения последних законов и распоряжений. При ведении бухгалтерского учета вручную возможны и простейшие арифметические ошибки.

Конечно, компьютер не может заменить опытного и грамотного бухгалтера, но позволит упорядочить бухучет, увеличить количество получаемой информации, повысить оперативность бухучета, уменьшить число арифметических ошибок, оценить текущее финансовое положение предприятия и его перспективы.

Глава 1. Планы видов характеристик и регистры расчета

1.1 Планы видов характеристик

Планы видов характеристик — это прикладные объекты конфигурации. Они предназначены для хранения информации о характеристиках различных объектов.

С их помощью пользователь может создавать всевозможные характеристики, описывать тип этих характеристик и задавать их значения. Например, для того, чтобы описывать товары произвольным количеством произвольных характеристик (цвет, размер, запах и т. д.).

Структура

По своей структуре план видов характеристик напоминает справочник: в плане видов характеристик хранятся элементы — характеристики, которые могут иметь некоторый набор реквизитов и табличных частей и, также как и элементы справочника, могут образовывать иерархические структуры. В плане видов характеристик могут существовать предопределенные характеристики, заданные разработчиком.

Однако основное назначение плана видов характеристик заключается в том, чтобы для каждой характеристики хранить тип значения, который она может принимать.

Рисунок 1. План видов характеристик Свойства объектов

Возможный перечень типов, которые могут принимать характеристики, указывается разработчиком в процессе создания прикладного решения.

Рисунок 2. Редактирование типа данных характеристик

Создавая новые характеристики (или редактируя существующие), пользователь сможет выбрать для них один из типов, входящих в этот перечень.

Однако не исключена ситуация, когда для создания очередной характеристики пользователю понадобится тип, не существующий в прикладном решении. Например, пользователь решит создать характеристику Запах, которая должна иметь значения справочника Запахи, но такого справочника в прикладном решении нет.

Специально для таких ситуаций разработчик может создать специальный пустой справочник, и указать, что в нем будут храниться дополнительные значения характеристик:

Рисунок 3. Указание дополнительных значений характеристик

Теперь, создавая характеристику Запах, пользователь сможет выбрать для нее тип значения этого специального справочника, а в самом справочнике создать нужные ему значения: Сладкий, Резкий, Кислый и т. д.

Формы плана видов характеристик

Для того чтобы пользователь мог просматривать и изменять данные, содержащиеся в плане видов характеристик, система поддерживает несколько форм его представления. Система может автоматически генерировать все нужные формы плана видов характеристик. Наряду с этим разработчик имеет возможность создать собственные формы, которые система будет использовать вместо форм по умолчанию.

Для просмотра данных, содержащихся в плане видов характеристик, используется форма списка. Она позволяет выполнять навигацию по плану, добавлять, помечать на удаление и удалять характеристики и группы характеристик, перемещать характеристики и группы. Форма списка может представлять данные в иерархическом и не иерархическом виде и позволяет выполнять сортировку и отбор отображаемой информации по нескольким критериям.

Рисунок 4. Типы форм планов видов характеристик

Для просмотра и изменения данных отдельных характеристик используется форма характеристики. Как правило, она представляет данные в удобном для восприятия и редактирования виде.

Кроме этого для планов видов характеристик, также как и для справочников, поддерживаются формы группы, выбора и выбора группы.

Рисунок 5. Форма характеристики

1. 2 Регистры расчета

Регистры расчета — прикладные объекты конфигурации, используемые в механизме сложных периодических расчетов и служащие для хранения записей о тех или иных видах расчета, которые необходимо выполнить, а также для хранения промежуточных данных и самих результатов выполненных расчетов.

Информация в регистре расчета хранится в виде записей, каждая из которых содержит значения измерений и соответствующие им значения ресурсов.

Измерения регистра описывают разрезы, в которых хранится информация, а ресурсы регистра непосредственно содержат хранимую информацию. Например, для регистра расчета Основные начисления работников организаций, который имеет следующую структуру:

Рисунок 6. Структура регистра расчета «Основные начисления»

записи, хранимые в базе данных, будут выглядеть следующим образом:

Рисунок 7. Вид регистра расчета «Основные начисления»

Регистр расчета связан с одним из планов видов расчета, существующих в прикладном решении. Эта связь обуславливает наличие у каждой записи регистра поля Вид расчета, благодаря которому механизмы регистра могут отслеживать взаимное влияние записей расчета друг на друга.

Так же регистр расчета хранит данные не только в разрезе созданных измерений, но и в разрезе времени. Это является причиной существования у каждой записи регистра расчета еще одного обязательного поля — Период действия. При создании регистра расчета разработчик может указать минимальную периодичность, с которой записи будут заноситься в регистр:

Изменение состояния регистра расчета происходит, как правило, при проведении документа. Поэтому каждая запись регистра связана с определенным документом — регистратором и номером строки этого документа. Добавление записей в регистр, их изменение и удаление возможно только одновременно для всех записей, относящихся к одному документу.

Рисунок 8. Задание периода регистра расчета

Для регистра расчета может быть указана связь с графиком времени. График времени представляет собой регистр сведений, в котором содержится временная схема исходных данных, участвующих в расчетах. Измерениями этого графика могут быть, например, график работы и дата, а ресурсом — количество рабочих часов в этой дате. Тогда можно будет связать запись регистра расчета с каким-либо конкретным графиком работы и в дальнейшем, средствами встроенного языка получать информацию о количестве рабочих часов, необходимую для выполнения расчетов.

Например, график времени, имеющий следующую структуру (рис. 9) может содержать информацию о количестве рабочих часов.

Рисунок 9. Структура графика времени «Рабочие часы»

Регистр расчета может включать в себя специальные объекты — Перерасчеты.

Рисунок 10. Структура перерасчетов

В этих объектах система будет хранить информацию о том, какие записи регистра расчета утратили свою актуальность и подлежат перерасчету в результате работы механизмов зависимости по базовому периоду и вытеснения по периоду действия.

Система обеспечивает контроль уникальности записей, хранящихся в регистре расчета. Поэтому в регистре расчета не может находиться двух записей, относящихся к одной и той же строке одного и того же документа.

Механизмы, реализуемые регистром расчета

Вытеснение по периоду действия

Механизм вытеснения по периоду действия позволяет рассчитывать фактический период действия записи регистра расчета на основании анализа других записей, содержащихся в регистре.

В общем случае, запись регистра расчета содержит две даты, определяющие период, на который распространяется действие данной записи. Этот период называется периодом действия записи. Однако, если вид расчета, к которому относится данная запись, может быть вытеснен другим видом расчета, то период действия данной записи является лишь «запрашиваемым» периодом, то есть «мы хотим, чтобы запись действовала в этом периоде». Реально, фактический период действия данной записи можно будет определить лишь после анализа всех записей видов расчета, которые вытесняют данный вид расчета по периоду действия. Фактический период действия будет представлять собой набор периодов, являющихся подмножеством исходного периода действия данной записи. Если не будет найдено ни одной записи, вытесняющей данную по периоду действия, то фактический период действия данной записи будет равен ее периоду действия. Другим крайним случаем вытеснения по периоду действия является полное вытеснение данной записи другими записями. В этом случае фактический период действия записи будет отсутствовать.

Каждая запись регистра расчета содержит вид расчета, к которому она относится. Чтобы определить, какие записи должны вытеснять данную запись по периоду действия, регистр расчета использует связь с планом видов расчета, в котором описано взаимное влияние видов расчета друг на друга. Использование этой связи позволяет регистру расчета определять фактический период действия каждой записи.

Зависимость по базовому периоду

Механизм зависимости по базовому периоду позволяет получать значение базы для записи регистра расчета на основании анализа других записей, содержащихся в регистре.

База представляет собой числовое значение, которое должно быть использовано для расчета результата данной записи. База рассчитывается путем анализа результатов расчета других записей, от которых данная запись зависит по базовому периоду. Таким образом, в общем случае, запись регистра расчета содержит две даты, определяющие период, в котором нужно анализировать записи видов расчета, от которых данный вид расчета зависит по базе — базовый период. Использование связи с планом видов расчета позволяет регистру расчета определять виды расчета, от которых данный вид расчета зависит по базовому периоду.

Регистр расчета поддерживает два вида зависимости по базовому периоду:

— зависимость по периоду действия;

— зависимость по периоду регистрации.

В случае зависимости по периоду действия для получения базы будут выбираться те записи, для которых найдено пересечение их фактического периода действия с базовым периодом данной записи. Значение базы, которая будет получена от конкретной влияющей записи, в общем случае не равно результату, который содержит эта запись. База будет рассчитана пропорционально тому, какую часть от фактического периода влияющей записи составляет перекрывающийся, с указанным базовым периодом, участок. При этом будут использованы данные графика, связанного с этой записью.

В случае зависимости по периоду регистрации для получения базы будут выбираться результаты расчета тех записей, которые попадают в базовый период данной записи значением своего поля «Период регистрации».

Наиболее сложным вариантом зависимости по базовому периоду является случай, когда для вида расчета данной записи установлено свойство «Период действия является базовым периодом». Это свойство означает, что в качестве базового периода данной записи будет использоваться не базовый период, который указан в соответствующих полях записи, а фактический период действия записи, получаемый в результате работы механизма вытеснения по периоду действия и являющийся, в общем случае, набором некоторых периодов.

Формирование записей перерасчета

Механизм формирования записей перерасчета отслеживает факт появления в регистре записей, влияющих на результат расчета уже существующих записей. Возможность влияния новых записей на существующие определяется в результате анализа взаимного влияния видов расчета и на основании работы механизмов вытеснения по периоду действия и зависимости по базовому периоду.

Результатом работы механизма формирования записей перерасчета является набор записей перерасчета, содержащий информацию о том, какие записи регистра должны быть рассчитаны заново (перерасчитаны).

Формы регистра расчета

Для того чтобы пользователь мог просматривать данные, содержащиеся в регистре расчета, система поддерживает форму представления регистра расчета — форму списка. Она позволяет выполнять сортировку и отбор отображаемой информации по нескольким критериям:

Рисунок 11. Форма списка регистра расчета

Система может автоматически генерировать эту форму. Наряду с этим разработчик имеет возможность создать собственные формы, которые система будет использовать вместо формы умолчанию, в том числе и форму набора записей, которая позволяет добавлять, изменять и удалять записи регистра расчета.

Функциональные возможности регистра расчета

Основными функциональными возможностями, которые предоставляет регистр расчета разработчику, являются:

— выбор записей в заданном интервале по заданным критериям;

— выбор записей по регистратору;

— получение значения базы для записей регистра, удовлетворяющих заданному отбору;

— получение данных графика для записей регистра, удовлетворяющих заданному отбору;

— получение данных о записях, подлежащих перерасчету;

— чтение, изменение и запись набора записей в регистр.

Глава 2. Решение задачи по оперативному учету

Задание.

Компания занимается оптовой торговлей. Поступление товаров отражается документом «Приходная накладная», продажа — «Расходная накладная». Учет товаров ведется в разрезе сроков годностей. При поступлении товара для каждого товара может быть указан свой срок годности.

Складской учет не ведется.

Списание себестоимости должно быть организовано по партиям в зависимости от срока годности. В том случае, если по разным партиям приходил товар с одинаковым сроком годности, в первую очередь необходимо списывать более дорогой товар.

В решении должна быть реализована возможность, как запрета, так и разрешения продажи товара, отсутствующего (по данным учета) на складе. Запрет продажи товара с «отрицательными остатками» или разрешение определяется учетной политикой организации, которая может меняться только в начале года.

Документы задним числом вводить нельзя, но можно открыть существующий документ и перепровести его.

Необходимо построить отчет по продажам товаров за период и остаткам товаров на указанную дату.

Продажи с 01. 01. 2013 по 31. 03. 2013.

Номенклатура

Количество

Себестоимость

Продажа

Прибыль

Куртка замшевая

3

300

620

320

Портсигар

3

30

50

20

Прибыль рассчитывается:

«Сумма продаж» — «Себестоимость»

Остатки товаров на 01. 01. 2013

Номенклатура

Партия

Количество

Стоимость

Куртка замшевая

4

350

Прих. Накладная № 1

2

250

Прих. Накладная № 2

2

100

Портсигар

6

65

Прих. Накладная № 1

5

50

Прих. Накладная № 2

1

15

Для решения были использованы следующие объекты конфигурации:

1. Справочники

1.1. Номенклатура

2. Документы

2.1. Приходная накладная

2.2. Расходная накладная

2.3. Установка цен номенклатуры

3. Регистры сведений

3.1. Цены

3.2. Учетная политика

4. Регистры накопления

4.1. Остатки товаров

4.2. Продажи

5. Отчеты

5.1. Остатки товаров

5.2. Продажи

Далее будут подробно рассмотрены их структура, назначение, а так же модули каждого из объектов и их форм.

2.1 Справочники

В данной конфигурации создан только один справочник «Номенклатура», который предназначен для хранения информации о товарном ассортименте фирмы. У этого справочника нет никаких дополнительных реквизитов, помимо стандартных — Наименование и Код.

Рисунок 12 Структура справочника «Номенклатура»

Для этого справочника используется стандартная форма элемента справочника. Дополнительные формы не создавались.

2. 2 Документы

Для решения задачи было добавлено три документа:

1. «Установка цен номенклатуры» — предназначен для установления цены продажи товаров, указанных в нем.

2. «Приходная накладная» — необходим для отражения поступления товаров на фирму.

3. «Расходная накладная» — используется для отражения реализации товаров фирмой-продавцом.

Структура этих документов показана на рисунках 13,14 и 15 соответственно.

Рисунок 13 Структура документа «Установка цен номенклатуры»

Рисунок 14. Структура документа «Приходная накладная»

Рисунок 15. Структура документа «Расходная накладная»

Документ «Установка цен номенклатуры» является регистратором для регистра сведений цены, который имеет структуру, показанную на рис. 16 и 17.

Рисунок 16. Структура регистра сведений «Цены»

Рисунок 17. Основные свойства регистра сведений «Цены»

Это значит, что при проведении документа «Установка цен номенклатуры» в регистре сведений «Цены» появляются новые строки. Изменения, вносимые в регистр сведений, производятся по алгоритму, указанному в процедуре «Обработка проведения» модуля документа «Установка цен номенклатуры»

Процедура ОбработкаПроведения (Отказ, Режим)

Движения. Цены. Записывать = Истина;

Движения. Цены. Очистить ();

Для Каждого ТекСтрокаЦены Из Цены Цикл

Движение = Движения. Цены. Добавить ();

Движение. Период = Дата;

Движение. Товар = ТекСтрокаЦены. Товар;

Движение. Цена = ТекСтрокаЦены. Цена;

КонецЦикла;

КонецПроцедуры

Форма документа «Приходная накладная» выглядит следующим образом.

Рисунок 18. Форма документа «Приходная накладная»

В табличную часть вносятся все поступившие товары и их характеристики. В поле «Сумма прихода» отражается сумма, на которую поступили все товары, указанные в табличной части.

Ниже представлен текст модуля формы данного документа

Процедура ТоварыТоварПриИзменении (Элемент)

// Пересчитывает цену при изменении товара

Количество=ЭлементыФормы. Товары. ТекущиеДанные. Количество;

Цена=ЭлементыФормы. Товары. ТекущиеДанные. ЦенаПокупки;

ЭлементыФормы. Товары. ТекущиеДанные. Сумма=Цена*Количество;

СуммаПрихода=Товары. Итог («Сумма»);

КонецПроцедуры

Процедура ТоварыКоличествоПриИзменении (Элемент)

// Пересчитывает цену при изменении количества

Количество=ЭлементыФормы. Товары. ТекущиеДанные. Количество;

Цена=ЭлементыФормы. Товары. ТекущиеДанные. ЦенаПокупки;

ЭлементыФормы. Товары. ТекущиеДанные. Сумма=Цена*Количество;

СуммаПрихода=Товары. Итог («Сумма»);

КонецПроцедуры

Процедура ТоварыЦенаПокупкиПриИзменении (Элемент)

// Пересчитывает цену при изменении цены

Количество=ЭлементыФормы. Товары. ТекущиеДанные. Количество;

Цена=ЭлементыФормы. Товары. ТекущиеДанные. ЦенаПокупки;

ЭлементыФормы. Товары. ТекущиеДанные. Сумма=Цена*Количество;

СуммаПрихода=Товары. Итог («Сумма»);

КонецПроцедуры

Процедура ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)

// Запрещает проведение документа «задним числом»

Если Дата< НачалоДня (ТекущаяДата ()) Тогда

Предупреждение («Не проведен!»);

Отказ=Истина;

КонецЕсли;

КонецПроцедуры

Вышеуказанный документ является регистратором для регистра накопления «Остатки товаров, который имеет структуру, показанную на рисунках 19 и 20.

Рисунок 19. Структура регистра накопления «Остатки товаров»

Рисунок 20. Основные свойства регистра накопления «Остатки товаров»

При проведении этого документа в регистре накопления возникают положительные движения, т. е. вид движения накопления — приход. Оприходование товаров регулируется процедурой «Обработка проведения» в модуле документа «Приходная накладная».

Процедура ОбработкаПроведения (Отказ, Режим)

Движения. ОстаткиТоваров. Записывать = Истина;

Движения. ОстаткиТоваров. Очистить ();

Для Каждого ТекСтрокаТовары Из Товары Цикл

Движение = Движения. ОстаткиТоваров. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Товар = ТекСтрокаТовары. Товар;

Движение. СрокГодности = ТекСтрокаТовары. СрокГодности;

Движение. Партия = Ссылка;

Движение. Количество = ТекСтрокаТовары. Количество;

Движение. Сумма = ТекСтрокаТовары. Сумма;

КонецЦикла;

Форма документа «Расходная накладная» показана на рисунке 21.

Рисунок 21. Форма документа «Расходная накладная»

В табличную часть заносятся те товары, которые подлежат реализации. Цена продажи заполняется при выборе товара из регистра сведений «Цены». В поле «Сумма расхода» заносится сумма продажи всех товаров, указанных в табличной части. Модуль формы выглядит следующим образом:

Процедура ТоварыТоварПриИзменении (Элемент)

// Пересчитывает сумму при изменении товара

Количество=ЭлементыФормы. Товары. ТекущиеДанные. Количество;

ТекДан=ЭлементыФормы. Товары. ТекущиеДанные;

Запрос = Новый Запрос;

Запрос. Текст = «ВЫБРАТЬ

| ЦеныСрезПоследних. Цена

|ИЗ

| РегистрСведений. Цены. СрезПоследних (&Дата, & Товар = Товар) КАК ЦеныСрезПоследних";

Запрос. УстановитьПараметр («Дата», Дата);

Запрос. УстановитьПараметр («Товар», ТекДан. Товар);

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();

Пока Выборка. Следующий () Цикл

//Подставляется цена из регистра сведений «Цены»

ТекДан. ЦенаПродажи=Выборка. Цена;

КонецЦикла;

ТекДан. Сумма=ТекДан. ЦенаПродажи*Количество;

СуммаРасхода=Товары. Итог («Сумма»);

КонецПроцедуры

Процедура ТоварыКоличествоПриИзменении (Элемент)

//Пересчитывает сумму при изменении количества

Количество=ЭлементыФормы. Товары. ТекущиеДанные. Количество;

ТекДан=ЭлементыФормы. Товары. ТекущиеДанные;

Запрос = Новый Запрос;

Запрос. Текст = «ВЫБРАТЬ

| ЦеныСрезПоследних. Цена

|ИЗ

| РегистрСведений. Цены. СрезПоследних (&Дата, & Товар = Товар) КАК ЦеныСрезПоследних";

Запрос. УстановитьПараметр («Дата», Дата);

Запрос. УстановитьПараметр («Товар», ТекДан. Товар);

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();

Пока Выборка. Следующий () Цикл

//Подставляется цена из регистра сведений «Цены»

ТекДан. ЦенаПродажи=Выборка. Цена;

КонецЦикла;

ТекДан. Сумма=ТекДан. ЦенаПродажи*Количество;

СуммаРасхода=Товары. Итог («Сумма»);

КонецПроцедуры

Процедура ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)

//Запрещает проведение документа «Задним числом»

Если Дата< НачалоДня (ТекущаяДата ()) Тогда

Предупреждение («Не проведен!»);

Отказ=Истина;

КонецЕсли;

КонецПроцедуры

Этот документ является регистратором для регистров накопления «Остатки товаров» и «Продажи». Их структура показана на рисунках 22−23 и 19−20 соответственно.

Рисунок 22. Структура регистра накопления «Продажи»

Рисунок 23. Основные свойства регистра накопления «Продажи»

Движения, создаваемые при проведении документа регулируются процедурой «Обработка проведения».

Процедура ОбработкаПроведения (Отказ, Режим)

Движения. ОстаткиТоваров. Записывать = Истина;

Движения. ОстаткиТоваров. Очистить ();

Движения. Продажи. Записывать = Истина;

Движения. Продажи. Очистить ();

Для Каждого ТекСтрокаТовары Из Товары Цикл

Запрос = Новый Запрос;

Запрос. Текст = «ВЫБРАТЬ

| ОстаткиТоваровОстатки. СрокГодности КАК СрокГодности,

| ОстаткиТоваровОстатки. Партия,

| ОстаткиТоваровОстатки. КоличествоОстаток как Кол,

| ОстаткиТоваровОстатки. СуммаОстаток как Сум,

| ВЫБОР

| КОГДА ОстаткиТоваровОстатки. КоличествоОстаток > 0

| ТОГДА ОстаткиТоваровОстатки. СуммаОстаток / ОстаткиТоваровОстатки. КоличествоОстаток

| ИНАЧЕ 0

| КОНЕЦ КАК Себестоимость

|ИЗ

| РегистрНакопления. ОстаткиТоваров. Остатки (&Дата, Товар = & Товар) КАК ОстаткиТоваровОстатки

|

|УПОРЯДОЧИТЬ ПО

| СрокГодности,

| Себестоимость УБЫВ";

Граница=Новый Граница (МоментВремени (), ВидГраницы. Исключая);

Запрос. УстановитьПараметр («Дата», Граница);

Запрос. УстановитьПараметр («Товар», ТекСтрокаТовары. Товар);

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();

НадоСписать=ТекСтрокаТовары. Количество;

Пока Выборка. Следующий () Цикл

Если НадоСписать< =Выборка. Кол Тогда

Движение = Движения. ОстаткиТоваров. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Товар = ТекСтрокаТовары. Товар;

Движение. СрокГодности =Выборка. СрокГодности;

Движение. Партия =Выборка. Партия;

Движение. Количество = НадоСписать;

Движение. Сумма = НадоСписать*Выборка. Себестоимость;

НадоСписать=0;

Прервать;

Иначе

Движение = Движения. ОстаткиТоваров. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Товар = ТекСтрокаТовары. Товар;

Движение. СрокГодности =Выборка. СрокГодности;

Движение. Партия =Выборка. Партия;

Движение. Количество = Выборка. Кол;

Движение. Сумма = Выборка. Сум;

НадоСписать=НадоСписать-Выборка. Кол;

КонецЕсли;

КонецЦикла;

Если НадоСписать>0 Тогда

Запрос = Новый Запрос;

Запрос. Текст = «ВЫБРАТЬ

|УчетнаяПолитикаСрезПоследних. РазрешитьСписаниеСОтрицательнымиОстатками КАК Политика

|ИЗ

| РегистрСведений. УчетнаяПолитика. СрезПоследних (&Дата,) КАК УчетнаяПолитикаСрезПоследних";

Запрос. УстановитьПараметр («Дата», Дата);

Результат = Запрос. Выполнить ();

Выборка = Результат. Выбрать ();

Пока Выборка. Следующий () Цикл

Если Выборка. Политика=Истина Тогда

Движение = Движения. ОстаткиТоваров. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Товар = ТекСтрокаТовары. Товар;

Движение. СрокГодности =0;

Движение. Партия = Документы. ПриходнаяНакладная. ПустаяСсылка ();

Движение. Количество = НадоСписать;

Движение. Сумма = 0;

Иначе

Сообщить («В строке №"+ТекСтрокаТовары. НомерСтроки+» товара «+ТекСтрокаТовары. Товар+» недостаточно на складе!");

Отказ=Истина;

КонецЕсли;

КонецЦикла;

КонецЕсли;

Движение = Движения. Продажи. Добавить ();

Движение. Период = Дата;

Движение. Товар = ТекСтрокаТовары. Товар;

Движение. Количество = ТекСтрокаТовары. Количество;

Движение. Сумма = ТекСтрокаТовары. Сумма;

КонецЦикла;

КонецПроцедуры

Так же по заданию необходимо реализовать возможность запрета и разрешения продажи товара, отсутствующего (по данным учета) на складе. Запрет продажи товара с «отрицательными остатками» или разрешение определяется учетной политикой организации, которая может меняться только в начале года.

Это можно реализовать с помощью регистра сведений «Учетная политика», структура которого показана на рисунках 24−25.

Рисунок 24. Структура регистра накопления «Учетная политика»

Рисунок 25. Основные свойства регистра накопления «Учетная политика»

Заключение

Автоматизация бухгалтерского учета на предприятии и подготовка финансовой отчетности в налоговые органы в условиях переходной экономики России является одной из наиболее важных задач. Ситуация такова, что сам по себе бухгалтерский учет на предприятии может рассматриваться как внутреннее дело предприятия, а основой для оценки финансово-хозяйственной деятельности предприятия со стороны государства служит отчетность (бухгалтерский баланс и многочисленные другие отчетные формы), которая должна ежеквартально предоставляться в налоговую инспекцию по месту регистрации предприятия. Кроме того, существуют плановые и внеплановые налоговые проверки, при проведении которых могут потребоваться все бухгалтерские документы, включая первичные.

В настоящее время существует широкий выбор различных систем автоматизации бухгалтерского учета. Не следует делить их на плохие и хорошие, сильные слабые. Все они хороши и их возможности находят практическое применение на предприятиях различного размера, профиля и рода деятельности.

Для того, чтобы перевод бухгалтерии на компьютер был эффективен и дал результат, следует учесть следующие аспекты.

Во-первых, важно правильно выбрать время для внедрения автоматизации и оценить ее сроки. Не следует вводить в эксплуатацию программы в «горячий сезон» и в период массовых отпусков сотрудников. Если требуется доработка типовой конфигурации, то обязательно нужно выделить время на подготовку технического задания и работу программистов внедренческой фирмы. Проверить, все ли аспекты деятельности фирмы учтены.

Во-вторых, уделить особое внимание подготовке персонала.

Взять в штат или по совместительству технического специалиста, который будет отвечать и поддерживать исправную работу техники, компьютерной сети, системного программного обеспечения.

Целесообразно предварительно провести обучение сотрудников работе за компьютером, новой программе и новым возможностям, которые она дает.

В-третьих, реально оценить возможности сотрудников и готовность автоматизируемых участков.

В-четвертых, необходимо организовать четкое взаимодействие всех автоматизируемых участков (складов, секций, бухгалтерии) и распределение функций по сотрудникам.

При автоматизации бухучета важно не просто перевести всю бумажную работу на компьютер. Важно, чтобы это увеличило эффективность работы бухгалтерии и улучшило контроль над финансово-хозяйственной деятельностью предприятия, что в свою очередь увеличит эффективность управления предприятием, и, как следствие, эффективность его работы.

Для того чтобы эффективно провести автоматизацию, следует, в первую очередь, хорошо представлять, что же такое автоматизированный бухучет. На первый взгляд все просто и даже такая постановка вопроса кажется несколько надуманной, потому что автоматизированный бухучет — это просто когда бухучет ведется на компьютере. Вот такое заблуждение и служит причиной большого количества неудачных попыток автоматизации.

Распространенным стереотипом является и то, что автоматизация бухучета приводит к сокращению бухгалтерского персонала, что приводит к страху перед автоматизацией. Несмотря на то, что, на первый взгляд, все логично — часть работы берет на себя компьютер, который и вытесняет бухгалтеров-людей, стереотип является ошибочным. Дело в том, что количество необходимых в бухгалтерии бухгалтеров зависит только от количества обрабатываемых бухгалтерией первичных документов (накладных, кассовых ордеров, платежек и пр.), а количество первичных документов не зависит от того, автоматизирован бухучет или нет, оно зависит от объема хозопераций в организации. Таким образом, автоматизация бухучета не уменьшает числа необходимых в бухгалтерии бухгалтеров.

конфигурация регистр отчет товар

Список литературы

1. Автоматизированные информационные технологии в экономике. / Под ред. Г. А. Титоренко. — М.: ЮНИТИ-ДАНА, 2008.

2. 1С: Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы — Изд. ООО «1С-Паблишинг», 2009.

3. Информационный ресурс «1С: Предприятие 8» — http: //v8. 1c. ru/

ПоказатьСвернуть
Заполнить форму текущей работой