Автоматизация складского учета

Тип работы:
Курсовая
Предмет:
Программирование


Узнать стоимость

Детальная информация о работе

Выдержка из работы

Содержание

Введение

Глава I. Анализ складского учета

1.1. Общие сведения, цели и задачи

1.2. Организационная структура

1.3. Информационная структура

1.4. Функциональная структура

1.5. Информационно-техническое обеспечение

Глава II. Разработка технического проекта

2.1. Обзор аналогичных систем

2.2. Эскиз технического задания

2.3. Логическая модель информационной системы

2.4. Физическая модель

Глава III. Реализация проекта

3.1. Разработка экранных форм

3.2. Разработка модулей для прикладных решений

3.3. Разработка отчетов

3.4. Роли пользователей

Заключение

Список использованной литературы

Приложения

Введение

Склад -- помещение (также и комплекс), предназначенное для хранения материальных ценностей и оказания складских услуг.

Складирование играет все возрастающую роль в жизни современного общества. Это обеспечивается ростом продаж и производителей, например, таких как, Китай.

Предмет исследования — автоматизация складского учета. Автоматизация является необходимым и перспективным процессом. Комплексное использование современных информационных технологий позволяет значительно облегчить работу склада.

Объект исследования — компьютерный магазин.

Функциональные возможности программы должны охватывать все возможные ситуации в работе склада. Программа должна поддерживать ведение базы товаров, поставщиков и сотрудников, а также обеспечивать правильное взаимодействие этих баз. Кроме того, необходимо обеспечение всех пользователей программы нужной им информацией в удобной форме.

Целью данного курсового проекта является разработка программы для автоматизации складского учета.

Задачами курсового проекта являются:

· описание предметной области,

· описание технологии функционирования ИС,

· физическое проектирование БД,

· разработка экранных форм ввода-вывода и отчетов.

Глава I. Анализ складского учета

1.1 Общие сведения, цели и задачи

Современные предприниматели всё чаще обращают свои взоры на рынок предоставления складских и логистических услуг. Оно и немудрено — уровень жизни в нашей стране постепенно растёт, что позволяет всё большему количеству граждан не экономить на складировании, а приобретать такие услуги у профессионалов. Поэтому склад — это хороший способ начать свой посреднический бизнес.

Склад выполняет три взаимосвязанные функции: Заказ и прием товаров, ее хранение и отгрузку.

Создаваемая программа предназначена для автоматизации складского учета. Она ведет учет товаров, учёт поставщиков и сотрудников, формирует необходимые документы и отчеты.

В базе данных разрабатываемого программного продукта будут хранится данные о товарах:

— код;

— наименование;

— единица измерения;

— группа товаров;

— цена;

Варианты товара, характеризуются следующими параметрами:

— код;

— название;

Также в программе содержатся данные о поставщиках:

— код поставщика;

— наименование;

— контактное лицо;

— ИНН;

— адрес;

Данные о сотрудниках будут характеризоваться следующими параметрами:

— код сотрудника;

— ФИО;

— должность;

— дата рождения;

— паспорт серия;

— паспорт номер;

— адрес;

— телефон;

— дата приема;

Содержится информация о складах:

— код склада;

— название.

В случае, когда сотрудник принимает заказ поставщика, формируется приходная накладная, в котором указываются следующие данные:

— код заказа;

— дата;

— сотрудник;

— поставщик;

— склад;

— наименование товаров;

— набор свойств;

— количество;

— цена;

— сумма.

Если сотрудники отгружают товар, то формируется расходная накладная, и в ней указываются следующие данные:

— код заказа;

— дата;

— МОЛ1;

— МОЛ2;

— склад;

— наименование товаров;

— набор свойств;

— количество;

— цена;

— сумма.

Когда сотрудник склада захочет пополнить товары на складе, то формируется документ «заказ на склад»:

— код;

— текущая дата;

— дата исполнения;

— Сотрудник;

— наименование товаров;

— набор свойств;

— количество;

— цена;

— сумма.

В случае когда сотрудник получил уведомление о заказе на склад, он договаривается с поставщиками о поставке и формируется документ «Заказ поставщику»:

— код;

— текущая дата;

— дата поставки;

— поставщик;

— объект основание;

— наименование товаров;

— количество;

— единица измерения;

Сотрудники благодаря данному программному продукту могут решать следующие задачи:

— регистрировать поставщиков;

— добавлять и удалять данные о товарах;

— составлять приходные и расходные накладные;

— вести учет товаров в целом;

— просматривать отчеты о движениях товаров.

1.2 Организационная структура

Процесс формирования организационной структуры включает в себя формулировку целей и задач, определение состава подразделений, их ресурсное обеспечение (включая численность работающих), разработку регламентирующих процедур, документов, положений, закрепляющих и регулирующих формы, методы, процессы, которые осуществляются в организационной системе управления.

Весь этот процесс можно организовать по трем крупным стадиям:

Формирование общей структурной схемы во всех случаях имеет принципиальное значение, поскольку при этом определяются главные характеристики организации, а также направления, по которым должно быть осуществлено более углублённое проектирование, как организационной структуры, так и др. важнейших аспектов системы (способность переработки информации).

Разработка состава основных подразделений и связей между ними — заключается в том, что предусматривается реализация организационных решений не только в целом по крупным линейно-функциональным и программно — целевым блокам, но и вплоть до самостоятельных (базовых) подразделений аппарата управления, распределения конкретных задач между ними и построения внутриорганизационных связей. Под базовыми подразделениями понимаются самостоятельные структурные единицы (отделы, сектора), на которые организационно разделяются линейно-функциональные и программно-целевые подсистемы. Базовые подразделения могут иметь свою внутреннюю структуру.

Регламентация организационной структуры — предусматривает разработку количественных характеристик аппарата управления и процедур управленческой деятельности. Она включает: определение состава внутренних элементов базовых подразделений (должностей); определение проектной численности подразделений; распределение задач и работ между конкретными исполнителями; установление ответственности за их выполнение; разработку процедур выполнения управленческих работ в подразделениях; расчёты затрат на управление и показателей эффективности аппарата управления в условиях проектированной организационной структуры.

Организационная структура магазина будет выглядеть следующим образом (рис. 1.2. 1).

Рис. 1.2.1. Организационная структура магазина.

1.3 Информационная структура

Управление можно рассматривать как информационный процесс. Функционирование организации возможно исключительно при наличии информации, необходимой для выработки и реализации управленческих решений. Информация в организации образует информационные потоки.

Информационная структура складского учета представлена на рисунке 1.3.1.

Информационная структура складского учета.

1. 4 Функциональная структура

Функциональная структура сложилась как неизбежный результат усложнения процесса управления. Особенность функциональной структуры заключается в том, что хотя и сохраняется единоначалие, но по отдельным функциям управления формируются специальные подразделения, работники которых обладают знаниями и навыками работы в данной области управления. информационный модуль проектирование складской

Функциональная структура складского учета

1.5 Информационно-техническое обеспечение

Информационно-техническое обеспечение — это просто жизненно необходимый элемент складского учета. На складе используется следующее информационно-техническое обеспечение:

1. Компьютер.

2. Фискальные регистраторы. Фискальный регистратор — это контрольно-кассовая машина, работающая только под управлением компьютера и соответствующего программного обеспечения. Фискальные регистраторы позволяют печатать на чеке наименования товара, размер предоставленной скидки, фамилию кассира и прочие данные, часто имеют авто-отрез чека. Как правило, они обладают повышенной надежностью.

В отличие от кассового аппарата, на печатающее устройство фискального регистратора, как на принтер, можно выводить любой документ. Счета клиентам можно печатать на фискальном регистраторе, при этом регистратор не фиксирует никаких сумм, а просто печатает. Фискальный регистратор обычно имеет разъём для подключения денежного ящика.

Глава II. Разработка технического проекта

2.1 Обзор аналогичных систем

Таблица 1

Сравнительная характеристика аналогичных систем

Программный продукт

Возможности

Фрегат Склад

ANALITIKA 2009 NET

SV: Склад

1С: Управление торговлей 8.

Штрихкодирование

+

+

+

-

Инвентаризация товаров

+

-

-

+

Управление складским персоналом

-

-

+

+

Размещение товара

+

+

+

+

Резервирование товары

-

-

-

+

Управление остатками товаров

-

+

+

+

Учет ГТД

-

-

-

+

Контроль приема и отгрузки товара

+

-

+

+

Расчет с поставщиками

-

+

-

+

Многоуровневая номенклатура

-

-

+

+

Учет сроков годности товаров

-

-

-

+

2.1.1 Программа «Фрегат Склад» [1]

Программное обеспечение «Фрегат Склад» — это система автоматизации управления складским хозяйством. «Фрегат Склад» позволяет организовывать хранение товаров, оптимизировать размещение товара на складе с учетом наличия свободных мест хранения, автоматизировать контроль приема и отгрузки с использованием технологии штрихкодов.

Основные функции «Фрегат Склад»:

— Настройка структуры мест хранения (стеллаж, ячейка и т. д.).

— Совмещение складских операций с хранением продуктов. Просмотр состояния товара при приемки и распределения по складским ячейкам.

— Добавление штрихкодов к товарам.

— Автоматическая маркировка товара для считывания штрихкодов и печати этикеток — сканеров.

— Контроль приема и отгрузки.

— Инвентаризация товаров с использованием устройства считывания штрихкодов.

Недостатками этой системы являются: сложность в освоении, неудобный интерфейс, дорогостоящие разработка.

2.1.2 Программа «ANALITIKA 2009 NET» [2]

Программный продукт для автоматизации ведения складского учета в малой компании. Имеется возможность ввода всех основных операций для торговых компаний. Из программы всегда можно вывести на принтер счет-фактуру, товарный чек, приходный складской ордер, расходный складской ордер, накладную на внутренние перемещения, приходный кассовый ордер, расходный кассовый ордер, платежное поручение.

Генераторы отчетов предоставляют информацию об остатках и оборотах товаров, материальных ценностей, услуг (количества, суммы по себестоимости и по ценам продажи), денежных средств, а также дают возможность рассчитывать задолженности по покупателям и по поставщикам на текущую дату и выбранный период. Во всех отчетах реализована возможность рассчитывать как количественные так и суммарные итоги по складам, магазинам, торговым точкам, группам товаров, кассам, сейфам и банковским счетам, а также по покупателям, поставщикам и прочим контрагентам.

Программа работает быстро, обрабатывает достаточно большие объемы данных без особого труда и не требовательна к аппаратным и программным средствам компьютера на котором инсталлирована. Сетевая версия для трех рабочих станций работающих с одной базой данных в локальной сети.

2.1.3 Программа «SV: Склад» [3]

SV: Склад -- Автоматизированная система управления складом с поддержкой ячеистого (адресного) склада.

Программа для склада SV: Склад -- предназначена для компаний, выросших из классического складского учета. Прием, размещение, перемещение, обработка, хранение, отгрузка -- при использовании системы автоматизации склада SV: Склад, технологии штрихового кодирования, адресного хранения и радиооборудования для передачи заданий работникам склада -- все эти операции можно сделать более эффективными, а вместе с ними и работу складского комплекса в целом.

Основные возможности:

— Большая многоуровневая номенклатура;

— Хранение необходимых дополнительных характеристик о товаре;

— Графическое отображение информации по физическому расположению стеллажей

— Широкие возможности фильтрации необходимой информации

— Оптимизация размещения принимаемого товара, а так же места хранения

— Оптимизация выдачи товара со склада

— Штрих сканеры и штрих принтеры

— Управление складским персоналом

— Распределение заданий между складскими сотрудниками

— Контроль выполненных работ

— Комплектование товара и печать комплектовочных документов

— Печать необходимых внутренних форм отчетности

Перечисленные функции, отражают небольшую часть возможностей системы складской автоматизации SV: Склад. Но также не надо забывать, что SV: Склад -- легко модернизируется в полноценную программу корпоративного учета SV: Учет, благодаря которой можно поставить управленческий учет на предприятии любой сложности.

2.1.4 Программа «1С: Управление торговлей 8» [4]

1С: Управление торговлей 8 — система учета и управления предприятием. Программа автоматизирует все направления торговой деятельности: складской учет и управление складскими запасами; розничная и оптовая торговля; анализ и планирование; работа с подотчетными лицами и т. д.

1С: Управление торговлей 8 позволяет:

— управлять остатками товаров в различных единицах измерения на множестве складов;

— вести раздельный учет собственных товаров, товаров, принятых и переданных на реализацию;

— учитывать серии товаров (серийные номера, сроки годности);

— задавать произвольные характеристики товаров (цвет, размер);

— учитывать ГТД и страну происхождения;

— резервировать товары.

Организация складского учета может быть различной, структура может быть как простой, так и иерархически сложной. Склады или места хранения могут быть как на территории предприятия, так, и расположены удаленно.

2.2 Эскиз технического задания

Назначение информационной системы — автоматизировать процесс работы складского учета

Целью разработки информационной системы является облегчение процесса учета товаров, а так же возможность формирования печатных форм документов, отчётов и других объектов конфигурации.

Необходимо разработать систему учёта, которая включает в себя:

1. Возможность учета товаров;

2. Формирование отчетов;

В системе учёта должны быть реализованы следующие функции:

1. Ведение базы данных товаров;

2. Возможность документального отражения в учётной программе всех этапов движения услуг;

3. Формирование текущих отчетов.

Для работы с данной информационной системой необходимо наличие на рабочей станции платформы «1С: Предприятия 8. 1». Визуальная среда разработки является неотъемлемой частью пакета программ «1С: Предприятие». (Под визуальной средой понимается Конфигуратор задач). Платформой предоставляется фиксированный набор базовых классов, ориентированных на решение типовых задач прикладной области.

Общие требования к техническому обеспечению:

1. Компьютеры в соответствии с системными требованиями платформы 1С: Предприятие 8.1. ;

2. Устройство вывода на печать.

2.3 Логическая модель информационной системы

Логический уровень — это абстрактный взгляд на данные, на нем данные представляют так, как выглядят в реальном мире. Объекты модели, представленные на логическом уровне, называются сущностями и атрибутами. Логическая модель данных может быть построена на основе другой логической модели, например, на основе модели процессов. Логическая модель данных является универсальной. Логическая модель данных описывает факты и объекты, подлежащие регистрации в ней. Устанавливаются связи между сущностями, определяются атрибуты и проводятся нормализация данных.

Рис. 2.3.1. Логическая модель информационной системы складского учета

2.4 Физическая модель

Дерево метаданных «Складской учет»

Константы

Наименование организации

ИНН организации

ОГРН организации

Юридический адрес

Телефон

Строка — 100

Строка — 12

Строка — 15

Строка — 100

Строка — 11

Перечисления

Единицы измерения

шт

Должность

Кладовщик

Грузчик

Товаровед

Программист

Бухгалтер

Справочники

Справочник. Поставщики

Код

Число — 10

Полное наименование

Строка — 50

ИНН

Строка — 12

Адрес

Строка — 100

Телефон

Строка — 11

Контактное лицо

Строка — 50

Справочник. Сотрудники

Реквизиты:

Код

Число — 10

Наименование

Строка — 50

Паспорт серия

Строка — 4

Паспорт номер

Строка — 6

Адрес

Строка — 100

Телефон

Строка — 11

Табличная часть: Данные

Должность

ПеречислениеСсылка. Должность

Дата приема

Дата

Справочник. Товары (2-х уровневый)

Код товара

Число — 10

Полное наименование

Строка — 50

Единица измерения

ПеречислениеСсылка. ЕдиницыИзмерения

Цена

Число (10), точность — 2, неотрицательное

Справочник. Склады

Код

Число — 10

Наименование склада

Строка — 50

Документы

Документы. ЗаказНаСклад

Шапка:

Дата исполнения документа

Дата

Сотрудник

Справочник. Сотрудники

Табличная часть: Товары

Наименование

Справочник. Товар

Количество

Число — 15, точность — 0

Цена

Число — 15, точность — 2

Сумма

Число — 15, точность — 2

Документы. ЗаказПоставщику

Шапка:

Поставщик

Справочник. Поставщики

Дата поставки

Дата

Табличная часть: Заказ

Наименование

Справочник. Товар

Количество

Число — 15, точность — 0

Сумма

Число — 15, точность — 2

Документы. ПриходнаяНакладная

Шапка:

Дата

Дата

Поставщик

Справочник. Поставщики

Склад

Справочник. Склады

Сотрудник

Справочник. Сотрудники

Табличная часть: Поставка

Наименование

Справочник. Товары

Количество

Число — 15, точность — 0

Цена

Число — 15, точность — 2

Сумма

Число — 15, точность — 2

Документы. РасходнаяНакладная

Шапка:

МОЛ 1

Справочник. Сотрудники

Склад

Справочник. Склады

МОЛ 2

Справочник. Сотрудники

Табличная часть: Выбытие

Товар

Справочник. Товар

Количество

Число — 15, точность — 0

Цена

Число — 15, точность — 2

Сумма

Число — 15, точность — 2

Документы. ПрайсЛист

Шапка:

Наименование поставщика

Справочник. Постащики

Табличная часть: Прайс

Наименование товара

Число — 10

Единица измерения

Число — 10

Цена

Число — 10, точность — 3, неотрицательное

Регистры

Регистры накопления

Регистры. ОстаткиНаСкладе {-РН}, {+Пн}

Измерения:

Склад

Справочник. Склады

Товар

Справочник. Товар

МОЛ 1

Справочник. Сотрудники

Ресурсы:

Количество

Число — 15, точность — 3

Регистры. ИсполнениеЗаказовПоставщиками{+зак. поставщику},{-ПН}

Измерение: Поставщик

Справочник. Поставщики

Ресурсы:

Поставщик

Товар

Справочник. Поставщики

Справочник. Товар

Количество

Число — 15, точность — 3

Регистры. ПоступлениеТовараНаСклад {+Пн}

Измерение:

Склад

СправочникСсылка. Склады

Наименование

СправочникСсылка. Товары

Поставщик

СправочникСсылка. Поставщики

Сотрудник

СправочникСсылка. Сотрудники

Ресурсы:

Число — 10

Количество

Число — 10

Цена

Число — 10

Стоимость

Число — 15

Регистры сведений

Регистры. Цена

Измерение:

Наименование товара

СправочникСсылка. Товары

Ресурсы:

Цена

Число — 10

Отчеты

Движение товара за период (регистр: ОстаткиНаСкладе)

Условия отбора:

· Склад

· Товар

· Период с

· Период по

Графы отчета:

· № п/п

· Товар (Строка)

· Начальный остаток (Число)

· Приход (Число)

· Расход (Число)

· Конечный остаток (Число)

Исполнение заказа поставщика (регистр: ЗаказПоставщику)

Условия отбора:

· Товар

· Период с

· Период по

Графы отчета:

· № п/п

· Товар (Строка)

· Заказано (Число)

· Исполнено (Число)

· Не исполнено (Число)

Поступление товара на дату (регистр: ПоступлениеТовараНаСклад

Отбор

· Товар

· Дата начала

· Дата окончания

Графы

· Дата (Число)

· Склад (Строка)

· Наименование товара (Строка)

· Вес (кг) (Число)

· Количество (Число)

· Цена (Число, 2 знака после запятой)

· Сумма (Число, 2 знака после запятой)

Глава II. Реализация проекта

2.1 Разработка экранных форм

Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа «Справочник».

Механизм поддержки справочников позволяет спроектировать и поддерживать самые различные справочники. На этапе конфигурирования можно описать, какими свойствами обладает каждый конкретный справочник. К настраиваемым свойствам относятся, например, длина и тип кода, количество уровней, поддержка уникальности кодов, набор реквизитов справочника.

Помимо кода и наименования, механизм работы со справочниками позволяет создавать набор реквизитов для хранения любой дополнительной информации об элементе справочника. Для реквизитов справочника возможно указание типа «Периодический» для отслеживания истории изменения значений реквизитов.

Для каждого справочника может быть задано несколько форм просмотра и редактирования.

Справочник «Сотрудники» предназначен для хранения информации о сотрудниках (рис. 3.1. 1). Справочник «Поставщики» предназначен для хранения информации о блюдах (рис. 3.1.2.). Справочник «Товары» позволяет хранить информацию о товарах (рис. 3.1. 3). В справочнике «Склад» используется информация о существующих складах (рис. 3.1.4.). Справочник «Варианты товара» предназначен для хранения альтернативных характеристик товара (рис. 3.1.5.). Справочник «Дополнительные свойства товара» предназначен для хранения дополнительной информации о товаре (рис. 3.1.6.).

Рис. 3.1.1 Форма справочника «Сотрудники»

Рис. 3.1.2 Форма справочника «Поставщики»

Рис. 3.1.3. Форма справочника «Товары»

Рис. 3.1.4. Форма справочника «Склады»

Рис. 3.1.5. Форма справочника «Варианты товара»

Рис. 3.1.6. Форма справочника «Дополнительные свойства товара»

3.2 Разработка модулей для прикладных решений

Документ -- одно из основных понятий системы «1С: Предприятие». При помощи документов организуется ввод в систему информации о совершаемых хозяйственных действиях, ее просмотр и, если необходимо, корректировка.

В большинстве своем документы, которые создаются в процессе настройки конфигурации, являются электронными аналогами стандартных бумажных документов, однако, использование этого типа данных может выходить далеко за рамки простой фиксации информации о хозяйственных операциях.

В конфигураторе создается, строго говоря, не сам документ, а средство ввода документа в компьютер -- шаблон документа. Каждый создаваемый в конфигураторе документ является описанием множества документов одного вида. Например, созданный в конфигураторе документ «Накладная» при работе с системой 1С: Предприятие позволит формировать накладные, которые будут иметь разное содержание, но одинаковый набор реквизитов, одинаковую логику поведения и так далее.

В информационной системе представлены следующие документы: Приходная накладная; Заказ поставщику; Расходная накладная; Прайс- Лист; Заказ на склад; Ввод начальных остатков.

Документ «Приходная накладная» предназначен для ввода закупленных продуктов (рис. 3.2.1.). Данный документ двигает регистр накопления «Остатки на складе», вид движения — приход. Другой документ «Заказ Поставщику» предназначен для ввода товаров для заказа (рис. 3.2.2.). Двигает регистр накопления «Исполнение заказов поставщиками», вид движения — приход.

Рис. 3.2.1. Форма документа «Приходная накладная»

Документ «Приходная накладная», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Приход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаПоставка. Наименование;

Движение. НаборСвойств=ТекСтрокаПоставка. НаборСвойств;

Движение. МОЛ = Сотрудник;

Движение. Количество = ТекСтрокаПоставка. Количество;

КонецЦикла;

// регистр ИсполнениеЗаказовПоставщиками Приход

Движения. ИсполнениеЗаказовПоставщиками. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ИсполнениеЗаказовПоставщиками. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Поставщик = Поставщик;

Движение. Товар = ТекСтрокаПоставка. Наименование;

Движение. Количество = ТекСтрокаПоставка. Количество;

КонецЦикла;

// регистр ПоступлениеТовараНаСклад Приход

Движения. ПоступлениеТовараНаСклад. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ПоступлениеТовараНаСклад. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Наименование = ТекСтрокаПоставка. Наименование;

Движение. Поставщик = Поставщик;

Движение. Сотрудник = Сотрудник;

Движение. Количество = ТекСтрокаПоставка. Количество;

Движение. Цена = ТекСтрокаПоставка. Цена;

Движение. Стоимость = ТекСтрокаПоставка. Сумма;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Рис. 3.2.2. Форма документа «Заказ поставщику»

Документ «Заказ поставщику», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ИсполнениеЗаказовПоставщиками Приход

Движения. ИсполнениеЗаказовПоставщиками. Записывать = Истина;

Для Каждого ТекСтрокаЗаказ Из Заказ Цикл

Движение = Движения. ИсполнениеЗаказовПоставщиками. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Поставщик = Поставщик;

Движение. Товар = ТекСтрокаЗаказ. Наименование;

Движение. Количество = ТекСтрокаЗаказ. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Процедура ОбработкаЗаполнения (ДанныеЗаполнения, СтандартнаяОбработка)

//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Если ТипЗнч (ДанныеЗаполнения) = Тип («СправочникСсылка. Поставщики») Тогда

// Заполнение шапки

Поставщик = ДанныеЗаполнения. Ссылка;

ОбъектОснование = ДанныеЗаполнения. Ссылка;

КонецЕсли;

//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

КонецПроцедуры

Документ «Расходная накладная» предназначен для ввода сбытых товаров (рис. 3.2.3.). Данный документ двигает регистр накопления «Остатки на складе», вид движения — расход.

Рис. 3.2.3. Форма документа «Расходная накладная»

Документ «Расходная накладная», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Расход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаВыбытие Из Выбытие Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаВыбытие. Товар;

Движение. МОЛ = МОЛ2;

Движение. Количество = ТекСтрокаВыбытие. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Прайс лист» предназначен для ввода цен на товары (рис. 3.2.4.). Данный документ двигает регистр накопления «Прайс лист», вид движения — приход.

Рис. 3.2.4. Форма документа «Прайс лист»

Документ «Прайс лист», модуль объекта

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ПрайсЛист Приход

Движения. ПрайсЛист. Записывать = Истина;

Для Каждого ТекСтрокаПрайс Из Прайс Цикл

Движение = Движения. ПрайсЛист. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Наименование = ТекСтрокаПрайс. Товар;

Движение. ЕдиницаИзмерения = ТекСтрокаПрайс. ЕдиницаИзмерения;

Движение. Цена = ТекСтрокаПрайс. Цена;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Заказ на склад» предназначен для заказа товаров на склад (рис. 3.2.5.).

Рис. 3.2.5. Форма документа «Заказ на склад»

Документ «Ввод начальных остатков» предназначен для ввода начальных остатков товара (рис. 3.2.6.).

Рис. 3.2.4. Форма документа «Прайс лист»

Документ «Прайс лист», модуль объекта

Процедура ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)

// Определить, нужно ли обновлять дату в движениях

ОбновитьДатуДвижений = ЭтоНовый () ИЛИ Движения. ОстаткиНаСкладе. Модифицированность ();

Если Не ОбновитьДатуДвижений Тогда

// Проверить, что дата изменилась

Запрос = Новый Запрос;

Запрос. УстановитьПараметр («ТекущийДокумент», Ссылка);

Запрос. Текст =

«ВЫБРАТЬ

| Дата

|ИЗ

| Документ. ВводНачальныхОстатков

|ГДЕ Ссылка = & ТекущийДокумент";

Выборка = Запрос. Выполнить (). Выбрать ();

Выборка. Следующий ();

ОбновитьДатуДвижений = Выборка. Дата < > Дата;

КонецЕсли;

// Установить всем новую дату, если нужно

Если ОбновитьДатуДвижений Тогда

Если Не Движения. ОстаткиНаСкладе. Выбран () И

Не Движения. ОстаткиНаСкладе. Модифицированность () Тогда

Движения. ОстаткиНаСкладе. Прочитать ();

КонецЕсли;

Для Каждого ЗаписьРегистра Из Движения. ОстаткиНаСкладе Цикл

ЗаписьРегистра. Период = Дата;

КонецЦикла;

КонецЕсли;

КонецПроцедуры

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Приход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаВвод Из Ввод Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаВвод. Товар;

Движение. МОЛ = ТекСтрокаВвод. Сотрудники;

Движение. Количество = ТекСтрокаВвод. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

3.3 Разработка отчетов

Для простоты работы с имеющейся информацией, в информационной системе были созданы следующие отчеты: Движение товара за период, Остатки товаров по свойствам, Поступление товара. Отчет «Движение товара за период» содержит сведения об остатках продуктов на складе за определенный период (рис. 3.3.1.). «Остатки товаров по свойствам» содержит сведения об остатках определенных продуктов на складе, которые соответствуют заданным свойствам (рис. 3.3.2.). «Поступление товара» позволяет получить информацию о поступлении товара на склад (рис. 3.3.4.).

Рис. 3.3.1. Отчет «Движение товара за период»

Рис. 3.3.2. Отчет «Остатки товаров по свойствам»

Рис. 3.3.3. Отчет «Поступление товара»

3. 4 Роли пользователей

Для разделения полномочий используются роли, которым назначаются права. Рассмотрим 2 роли.

Роль директор (рис. 3.4.1.). Права:

— просмотр и чтение документов;

— возможность изменять реквизиты организации.

Рис. 3.4.1. Документ «Роль: Директор». Вкладка Права

Роль кладовщик (Рис. 3.4.2.). Права на возможность изменять такие документы, как:

— заказ на склад;

— приходная накладная;

— расходная накладная;

— остатки на склад;

— поступление на склад;

— ввод начальных остатков;

— просмотр прайс-листов.

Рис. 3.4.1. Документ «Роль: Кладовщик». Вкладка Права

Заключение

Неоспоримым преимуществом автоматизированных систем управления является то, что они не требуют никаких дополнительных вложений. Автоматизированные системы управления достаточно легко поддаются необходимым корректировкам в соответствии с требованиями рабочего процесса предприятия.

В результате выполнения данного курсового проекта все поставленные цели и задачи были выполнены. Были описаны технологии функционирования ИС, выполнено физическое проектирование БД, разработаны экранные форм ввода-вывода и отчеты, разработаны функциональные модули.

В результате проделанной работы было разработано приложение для работы складского учета. Оно автоматизирует доступ к базе данных и оптимизирует работу персонала.

Информационная система разработана на платформе «1С: Предприятие» версии 8.2. Данный выбор обусловлен широкими возможностями по ведению учета хозяйственных операций, предоставляемыми системой.

Список использованной литературы

1. Информационный сервер «Softline»". Электр. ресурс 1: Фрегат Склад. Режим доступа: http: //store. softline. ru/fregat-it/fregat-sklad/

2. Информационный сервер «Business Software Laboratory». Электр. ресурс 1: ANALITIKA 2009 NET. Режим доступа: http: //www. bsoftlab. net/analitika2009net. htm

3. Информационный сервер «ERP CRM WMS». Электр. ресурс 1: SV: Склад. Режим доступа: http: //erp-crm-wms. ru/wms-svsklad-wms-sistema-avtomatizirovannaya-sistema-programm-skladskogo-ucheta/

4. Информационный сервер «Фирма 1С». Электр. ресурс 1: 1С: Управление торговлей 8. Режим доступа: http: //softrm. ru/ut8general/storage

5. Белоусов, П. Н., Островерх, А. Д. 1С: Предприятие: от 8.0 к 8. 1[Текст] / П. Н. Белоусов, А. Д. Островерх. — Питер: «1С-Паблишинг», 2008. — 577 стр.

6. Вендров, А. М. Проектирование программного обеспечения экономических информационных систем: Учебник для студентов, обучающихся по специальности «Прикладная информатика» и «Прикладная математика и информатика [Текст] / А. М. Вендров. — М.: Финансы и статистика, 2001. — 221 с.

7. Габец, А. П., Гончаров, Д. И. 1С: Предприятие 8.1. Простые примеры разработки [Текст] / А. П. Габец, Д. И. Гончаров. — Питер: «1С-Паблишинг», 2009. — 383 стр.

8. Информационные системы в экономике в вопросах и ответах: Учебн. пособие. — М.: Т К Велби, Издательство «Проспект», 2004. — 280 с.

9. Маклаков, С. В. BPwin и ERwin. CASE — средства разработки информационных систем. Учебное пособие [Текст] / С. В. Маклаков. -Москва: Диалог — МИФИ, 1999. — 256с.

10. Радченко, М. А. 1С: Предприятие 8.1. Практическое пособие разработчика. Примеры и типовые приемы [Текст] / М. А. Радченко. — Питер: «1С-Паблишинг», 2009. — 512 стр.

11. Хрусталева, Е. Ю. Разработка сложных отчетов в 1С: Предприятии 8 Система компоновки данных [Текст] / Е. Ю. Хрусталева — Питер: «1С-Паблишинг», 2009. — 489 стр.

12. Борисов, В. В. Компьютерная поддержка сложных организационно- технических систем. [Текст]:/ В. В Борисов, И. А. Бычков, А. В. Дементьев. — Горячая линия — Телеком, 2002 -300с.

13. Гайдамакин, Н. А. Автоматизированные информационные системы, базы и банки данных. ввод. курс [Текст]: учеб. пособие для вузов ./ Н. А. Гайдамакин — М.: Гелиос АРВ, 2002. — 101 с.

14. Баженова, И. Ю. Основы проектирования приложений баз данных. [Текст]: учеб. пособие ./ И. Ю. Баженова — М.: Интернет-Ун-т Информ Технологий БИНОМ. Лаб. знаний, 2006. — 252 с.

15. Сайт компании 1с [Электронный ресурс] URL: http: //www. 1с. ru

Приложения

Общий модуль «Работа с документами»:

& НаКлиенте

Процедура РассчитатьСумму (СтрокаТабличнойЧасти)Экспорт

СтрокаТабличнойЧасти. Сумма=СтрокаТабличнойЧасти. Количество * СтрокаТабличнойЧасти. Цена;

КонецПроцедуры

Документ «Приходная накладная», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Приход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаПоставка. Наименование;

Движение. НаборСвойств=ТекСтрокаПоставка. НаборСвойств;

Движение. МОЛ = Сотрудник;

Движение. Количество = ТекСтрокаПоставка. Количество;

КонецЦикла;

// регистр ИсполнениеЗаказовПоставщиками Приход

Движения. ИсполнениеЗаказовПоставщиками. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ИсполнениеЗаказовПоставщиками. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Поставщик = Поставщик;

Движение. Товар = ТекСтрокаПоставка. Наименование;

Движение. Количество = ТекСтрокаПоставка. Количество;

КонецЦикла;

// регистр ПоступлениеТовараНаСклад Приход

Движения. ПоступлениеТовараНаСклад. Записывать = Истина;

Для Каждого ТекСтрокаПоставка Из Поставка Цикл

Движение = Движения. ПоступлениеТовараНаСклад. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Наименование = ТекСтрокаПоставка. Наименование;

Движение. Поставщик = Поставщик;

Движение. Сотрудник = Сотрудник;

Движение. Количество = ТекСтрокаПоставка. Количество;

Движение. Цена = ТекСтрокаПоставка. Цена;

Движение. Стоимость = ТекСтрокаПоставка. Сумма;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Приходная накладная», модуль формы:

& НаКлиенте

Процедура ПоставкаКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Поставка. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

& НаКлиенте

Процедура ПоставкаЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Поставка. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти);

КонецПроцедуры

& НаКлиенте

Процедура Подбор (Кнопка)

ПараметрыФормы = Новый Структура («ЗакрыватьПриВыборе, МножественныйВыбор», Ложь, Истина);

ОткрытьФорму («Справочник. Товары. ФормаВыбора», ПараметрыФормы, Элементы. Поставка);

КонецПроцедуры

& НаКлиенте

Процедура ПоставкаОбработкаВыбора (Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

Для Каждого ВыбранныйЭлемент Из ВыбранноеЗначение Цикл

НоваяСтрока=Объект. Поставка. Добавить ();

НоваяСтрока. Наименование=ВыбранныйЭлемент;

КонецЦикла

КонецПроцедуры

Документ «Заказ поставщику», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ИсполнениеЗаказовПоставщиками Приход

Движения. ИсполнениеЗаказовПоставщиками. Записывать = Истина;

Для Каждого ТекСтрокаЗаказ Из Заказ Цикл

Движение = Движения. ИсполнениеЗаказовПоставщиками. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Поставщик = Поставщик;

Движение. Товар = ТекСтрокаЗаказ. Наименование;

Движение. Количество = ТекСтрокаЗаказ. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Процедура ОбработкаЗаполнения (ДанныеЗаполнения, СтандартнаяОбработка)

//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Если ТипЗнч (ДанныеЗаполнения) = Тип («СправочникСсылка. Поставщики») Тогда

// Заполнение шапки

Поставщик = ДанныеЗаполнения. Ссылка;

ОбъектОснование = ДанныеЗаполнения. Ссылка;

КонецЕсли;

//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

КонецПроцедуры

Документ «Расходная накладная», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Расход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаВыбытие Из Выбытие Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Расход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаВыбытие. Товар;

Движение. МОЛ = МОЛ2;

Движение. Количество = ТекСтрокаВыбытие. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Расходная накладная», модуль формы:

& НаКлиенте

Процедура ВыбытиеЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Выбытие. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти)

КонецПроцедуры

& НаКлиенте

Процедура ВыбытиеКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Выбытие. ТекущиеДанные;

РаботаСДокументами. РассчитатьСумму (СтрокаТабличнойЧасти)

КонецПроцедуры

Документ «Прайс лист», модуль объекта:

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ПрайсЛист Приход

Движения. ПрайсЛист. Записывать = Истина;

Для Каждого ТекСтрокаПрайс Из Прайс Цикл

Движение = Движения. ПрайсЛист. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Наименование = ТекСтрокаПрайс. Товар;

Движение. ЕдиницаИзмерения = ТекСтрокаПрайс. ЕдиницаИзмерения;

Движение. Цена = ТекСтрокаПрайс. Цена;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

Документ «Заказ на склад», модуль формы:

& НаКлиенте

Процедура ТоварыКоличествоПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Товары. ТекущиеДанные;

СтрокаТабличнойЧасти. Сумма = СтрокаТабличнойЧасти. Количество*

СтрокаТабличнойЧасти. Цена;

КонецПроцедуры

& НаКлиенте

Процедура ТоварыЦенаПриИзменении (Элемент)

СтрокаТабличнойЧасти = Элементы. Товары. ТекущиеДанные;

СтрокаТабличнойЧасти. Сумма = СтрокаТабличнойЧасти. Количество*

СтрокаТабличнойЧасти. Цена;

КонецПроцедуры

Документ «Ввод начальных остатков», модуль объекта:

Процедура ПередЗаписью (Отказ, РежимЗаписи, РежимПроведения)

// Определить, нужно ли обновлять дату в движениях

ОбновитьДатуДвижений = ЭтоНовый () ИЛИ Движения. ОстаткиНаСкладе. Модифицированность ();

Если Не ОбновитьДатуДвижений Тогда

// Проверить, что дата изменилась

Запрос = Новый Запрос;

Запрос. УстановитьПараметр («ТекущийДокумент», Ссылка);

Запрос. Текст =

«ВЫБРАТЬ

| Дата

|ИЗ

| Документ. ВводНачальныхОстатков

|ГДЕ Ссылка = & ТекущийДокумент";

Выборка = Запрос. Выполнить (). Выбрать ();

Выборка. Следующий ();

ОбновитьДатуДвижений = Выборка. Дата < > Дата;

КонецЕсли;

// Установить всем новую дату, если нужно

Если ОбновитьДатуДвижений Тогда

Если Не Движения. ОстаткиНаСкладе. Выбран () И

Не Движения. ОстаткиНаСкладе. Модифицированность () Тогда

Движения. ОстаткиНаСкладе. Прочитать ();

КонецЕсли;

Для Каждого ЗаписьРегистра Из Движения. ОстаткиНаСкладе Цикл

ЗаписьРегистра. Период = Дата;

КонецЦикла;

КонецЕсли;

КонецПроцедуры

Процедура ОбработкаПроведения (Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр ОстаткиНаСкладе Приход

Движения. ОстаткиНаСкладе. Записывать = Истина;

Для Каждого ТекСтрокаВвод Из Ввод Цикл

Движение = Движения. ОстаткиНаСкладе. Добавить ();

Движение. ВидДвижения = ВидДвиженияНакопления. Приход;

Движение. Период = Дата;

Движение. Склад = Склад;

Движение. Товар = ТекСтрокаВвод. Товар;

Движение. МОЛ = ТекСтрокаВвод. Сотрудники;

Движение. Количество = ТекСтрокаВвод. Количество;

КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры

ПоказатьСвернуть
Заполнить форму текущей работой