Автоматизированная система учета риэлтерских операций

Тип работы:
Курсовая
Предмет:
Программирование


Узнать стоимость

Детальная информация о работе

Выдержка из работы

Федеральное агентство образования Российской Федерации

Белгородский государственный университет

Факультет компьютерных наук и телекоммуникаций

Кафедра информатики и программирования

ПОЯСНИТЕЛЬНАЯ ЗАПИСКА

К КУРСОВОЙ РАБОТЕ

по дисциплине: «Разработка экономических информационных систем»

на тему: «Автоматизированная система учета риэлтерских операций»

Белгород 2007

План

Введение

1. Анализ предметной области и описание функций проектируемой системы

2. Проектирование автоматизированной системы учета риэлтерских операций

3. Разработка автоматизированной системы учета риэлтерских операций

3.1 Создание объектов типа «Константа», «Справочник», «Перечисление», «Регистр сведений»

3.2 Создание объектов типа «Документ», «Регистр накопления», «Отчет»

Заключение

Список использованных источников

Приложения

Введение

Предметом данной курсовой работы является деятельность риэлторской фирмы, которая напрямую связана с оперативной обработкой большого объёма информации об объектах недвижимости. Такой объект, как недвижимость, имеет множество характеристик, которые достаточно легко укладываются в чёткую схему, что позволяет эффективно использовать компьютер для хранения и обработки этих данных. Так как каждая риэлторская фирма использует свои методы работы с клиентами и учёта объектов недвижимости, то универсального программного обеспечения, устроившего всех, не существует. При разработке подобного комплекса программ приходится подробно знакомиться с методами работы конкретной фирмы, с её системой учёта. При попытке сделать систему более универсальной разработчик непременно сталкивается со справедливым противодействием со стороны заказчика, так как эта попытка приведёт к снижению эффективности использования системы в специфических условиях данной фирмы.

Курсовая работа предназначена для углубления теоретических и практических навыков проектирования и разработки информационных систем на платформе 1С: Предприятие 8.0.

Задача курсовой работы состоит в создании программного комплекса для автоматизации деятельности риэлторской фирмы. В ней производится глубокий анализ деятельности фирмы, разработка функциональных требований, а также разработка автоматизированной системы, отвечающей этим требованиям.

Данная курсовая работа состоит из введения, трех разделов, заключения, списка использованной литературы и трех приложений и размещена на 44 страницах.

1. Анализ предметной области и описание функций проектируемой системы

Организации (предприятия), которые действуют на рынке недвижимости, могут называться по-разному:

· Брокерская (маклерская) контора;

· Агентство недвижимости;

· Риэлторская фирма (контора).

Название фирмы «риелторская» происходит от английского слова realty, что означает недвижимое имущество.

Недвижимое имущество — это такое имущество, которое нельзя передвинуть, не нанеся ему существенных повреждений, а именно: всякого рода строения или их части, а также земельные участки. Рынок недвижимости — это совокупность сделок, предметом которых является недвижимое имущество. Причем, спектр таких сделок достаточно широк. Это и купля-продажа, и мена, и имущественный наем (аренда), и договоры пожизненного содержания и т. п.

Можно определить основные виды предпринимательской деятельности на рынке недвижимости:

· информационные услуги;

· консультации;

· посреднические операции;

· торговая деятельность.

Информационные услуги — наиболее распространенный вид деятельности. Сущность заключается в сборе информации о спросе и предложении на рынке недвижимости и предоставлении клиенту информации о возможных вариантах сделок. Клиент, выбрав подходящий вариант, самостоятельно или с технической помощью риелтора заключает сделку. Этот вид деятельности на рынке недвижимости является наиболее простым, с него начинали свою работу большинство агентств недвижимости. Услуги риэлтора здесь сводятся, в основном, к подбору вариантов, а также к сопутствующим услугам, таким как предоставление помещения для переговоров, показ клиенту объекта недвижимости, договоренность с нотариусом о времени и месте подписания сделки, предоставление транспорта и т. п. Простота этого вида деятельности обуславливает и его недостатки. Так, риэлтора всегда беспокоит, что стороны, познакомятся лично и могут, обойтись и без него, тем более что предотвратить такой исход законными средствами весьма затруднительно.

Консультационные услуги — тоже довольно распространенный в настоящее время вид деятельности на рынке недвижимости. Кроме того, он наиболее обширен и разнообразен. Заключается в предоставлении клиенту различного рода консультаций по вопросам, так или иначе имеющим отношение к объектам недвижимости. Консультации можно классифицировать по областям знаний. В частности к объектам недвижимости могут иметь отношение:

· юридические консультации (по вопросам правоотношений, связанных с объектами недвижимости);

· технические консультации (о техническом состоянии объекта недвижимости, его технических и эксплуатационных характеристиках и свойствах, необходимость ремонта и т. д.);

· экономические консультации (стоимость объекта, ликвидность, экономика инвестиций, окупаемость и т. п.).

Закон «О налогообложении прибыли предприятий» определяет посредническую операцию как хозяйственную операцию субъекта предпринимательской деятельности, который выступает в роли комиссионера в договоре комиссии, консигнатора в консигнационном договоре либо поверенного в договоре поручения. Поскольку консигнация предусматривает экспорт материальных ценностей на склад, а экспортировать объект недвижимости, тем более на склад не представляется возможным, посреднические операции на рынке недвижимости возможны только в виде договоров поручения или комиссии. По договору поручения одна сторона (поверенный) обязуется исполнить от имени и за счет другой стороны (доверителя) определенные действия. То есть, риэлтор, выступая в качестве поверенного, от имени и за счет клиента (доверителя) участвует в заключении сделки. Это может быть купля, продажа, мена, аренда, т. е. практически любая сделка. При этом права и обязанности заключенной сделки возникают у клиента. Риэлтор, несмотря на то, что он является активным участником сделки, юридически остается «в стороне». Он не несет ответственность за исполнение сделки сторонами. За оказанные услуги (то есть за заключение сделки) риелтор получает от клиента плату. По договору комиссии одна сторона (комиссионер) обязуется по поручению другой стороны (комитента) за вознаграждение совершить одну или несколько сделок от своего имени и за счет клиента (комитента). Это также может быть практически любая сделка. Существенным отличием договора комиссии от договора поручения является то, что права и обязанности по заключенной комиссионером сделки возникают у последнего (у комиссионера), даже если комитент был назван в сделке или вступил с третьим лицом в непосредственные отношения относительно исполнения сделки. Комиссионер не отвечает перед комитентом за исполнение заключенной комиссионером за счет комитента сделки. Однако комиссионер может принять на себя поручительство за исполнение третьим лицом этой сделки (делькредере).

Наиболее частый в деятельности риэлтора — договор на предоставление посреднических услуг. По нему клиент-заказчик поручает, а риелтор-посредник обязуется:

· исполнить ряд действий с целью нахождения оптимального покупателя, готового приобрести объект заказчика — продавца;

· содействовать заказчику при заключении «Договора купли — продажи».

Если рассмотреть работу риэлторской фирмы, которая предоставляет информационные и консультационные услуги, детально, то можно выделить следующие аспекты:

· работа с продавцами (арендодателями) недвижимого имущества. В этот аспект входят следующие направления: предоставление продавцом (арендодателем) документа, удостоверяющего личность (паспорт или др.), документов, подтверждающих его права собственности или полномочия на объект недвижимости, подписание соглашения о представлении интересов продавца (арендодателя) при продаже (сдачи в аренду) имущества, ввод данных о недвижимом имуществе в автоматизированную систему.

· работа с потенциальными покупателями (арендаторами). В этот аспект входят следующие направления: поиск подходящих вариантов объекта купли-продажи (аренды), ознакомление с планировкой и расположением недвижимого имущества (по документации или с помощью выезда непосредственно на объект), предоставление покупателем (арендатором) личных данных, подтвержденных документально (удостоверение личности, паспорт, свидетельство о рождении, военный билет и т. д.), подписание договора по оказанию услуг.

· подготовка документов. Для отчуждения жилья необходима следующая документация: правоустанавливающий документ, справка-характеристика (БТИ), справка об отсутствии ареста на жилье, наличие при подписании всех собственников и их паспортов (в случае отсутствия — доверенность), а также супругов (в случае необходимости), решение опекунского совета (в случае необходимости). Во время проведения сделки обе стороны, покупатель и продавец, подписывают передаточный акт и договор купли-продажи. В случае аренды арендодатель и арендатор подписывают договор аренды. Эти документы риелтор должен подготовить к дате проведения сделки. Для этого ему нужны следующие данные: фамилия, имя отчество и другие данные, содержащиеся в удостоверениях личностей продавца и покупателя, краткая характеристика объекта недвижимости;

· проведение сделки.

В данной курсовой работе проектируется система, пользователи которой — риэлторы. Таким образом, главной задачей данной системы является автоматизация работы риэлтора, который по роду своей деятельности имеет дело с большими массивами информации (данные об объектах недвижимости, их продавцах и т. д.). В соответствии с вышеперечисленными аспектами работы риэлторской фирмы можно выделить следующие процессы деятельности, для автоматизации которых предназначена система:

· хранение данных, необходимых для подготовки документов и проведения сделки: данные о продавце (арендодателе), покупателе (арендаторе), объекте недвижимости.

· учет персонала, занимающегося риэлторской деятельностью.

· поиск вариантов объекта недвижимости по конкретным параметрам, удовлетворяющих потенциального покупателя (арендатора).

· составление документов (соглашения о предоставлении интересов продавца (арендодателя) и договора по оказанию услуг).

· учет сделок с объектами недвижимости.

· составление отчетов о риэлторской деятельности.

2. Проектирование автоматизированной системы учета риэлтерских операций

Проектируемая система будет в дальнейшем разрабатываться на платформе «1С: Предприятие 8. 0». Платформа «1С: Предприятие» представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов предметной области. Конкретный набор объектов, структуры информационных массивов, алгоритмы обработки информации определяет конкретная конфигурация. Вместе с конфигурацией система «1С: Предприятие» выступает в качестве уже готового к использованию программного продукта, ориентированного на определенные типы предприятий и классы решаемых задач.

Согласно логике выбранной платформы для автоматизации процессов, рассмотренных в первом разделе можно выделить ряд объектов конфигурации, представленный в таблице 1.

Таблица 1 Объекты проектируемой системы

Типы объектов

Объекты

Справочники

Клиенты

Сотрудники

Вид ОН

Города

Районы

Улицы

Состояние

Балкон

Водоснабжение

Отопление

Планировка дома

Тип населенного пункта

Тип улицы

Перечисления

Юр./ физ. лицо

Операция

Санузел

Константы

НазваниеОрганизации

ИНН

КПП

РасчетныйСчет

Адрес

Телефоны

Директор

Регистры сведений

Процент

Документы

Предложение

Спрос

Регистры накопления

Объекты недвижимости

Услуги

Отчеты

Выбор ОН

Услуги

учет риэлтерский автоматизированный отчет

Рассмотрим данные объекты подробнее.

Справочник «Клиенты» содержит информацию о продавцах (арендодателях) и покупателях (арендаторах), обратившихся в данное агентство информационными и консультационными услугами. Это может быть как юридическое, так и физическое лицо. Для этого данный справочник содержит следующие реквизиты, представленные в таблице 2.

Таблица 2 Реквизиты справочника «Клиенты»

Реквизит

Тип

Хранимые данные

ЮрФизЛицо

ПеречислениеСсылка. Юр-ФизЛицо

Юридическая организация клиента

НаименованиеПолное

строка, длина неограниченная

ФИО/Наименование юридического лица

Документ

строка, длина неограниченная

Удостоверение физического лица

ДатаРождения

дата

Дата рождения физического лица

Адрес

строка, длина неограниченная

Адрес регистрации

ИНН

строка, длина 12

ИНН юридического лица

КПП

строка, длина 9

КПП юридического лица

АдресФактический

строка, длина неограниченная

Фактический адрес

Телефон

строка, длина 25

Телефоны

Представитель

строка, длина неограниченная

ФИО представителя юридического лица

Для удобства поиска и навигации справочник имеет иерархическую структуру. Для хранения информации о сотрудниках агентства предусмотрен справочник «Сотрудники». Для отображения в информационной системе всех необходимых данные о сотрудниках в данном справочнике предусмотрен ряд реквизитов, представленный в таблице 3.

Таблица 3 Реквизиты справочника «Сотрудники»

Реквизит

Тип

Хранимые данные

ПолноеНаименование

строка, длина неограниченная

ФИО

ДатаРождения

дата

Дата рождения

Документ

строка, длина неограниченная

Удостоверение личности

АдресПрописки

строка, длина неограниченная

Адрес регистрации

Адрес

строка, длина неограниченная

Фактический адрес

Телефон

строка, длина 25

Телефоны

Такие справочники, как «Вид ОН», «Состояние», «Балкон», «Водоснабжение», «Отопление», «Планировка дома» служат для хранения характеристик объектов недвижимости и не содержат реквизитов. Справочники «Города», «Районы», «Улицы» предназначены для удобного ввода адреса объекта недвижимости, а также организации поиска объекта в отчете «Выбор ОН». Справочник «Города» имеет один реквизит «ТипНаселенногоПункта» типа «СправочникСсылка. ТипНаселенногоПункта», в котором находится информация о принадлежности населенного пункта к определенному виду. Аналогично связаны справочники «Улицы» и «Тип улицы». Перечисления предназначены для хранения постоянных значений. В таблице 4 рассмотрены значения перечислений, необходимых при работе риэлтора с информационной системой.

Таблица 4 Значения перечислений

Наименование перечисления

Значения перечисления

ЮрФизЛицо

ЮрЛицо, ФизЛицо

Операция

ПокупкаПродажа, Аренда

Санузел

Сдельный, Раздельный

Документ «Предложение» предназначен для ввода и хранения в системе данных об объектах недвижимости, предлагаемых клиентами агентства для дальнейшей их продажи (сдачи в аренду). Ввиду этого данный объект содержит ряд реквизитов, которые изложены в таблице 5.

Таблица 5 Реквизиты документа «Предложение»

Реквизит

Тип

Хранимые данные

Операция

ПеречислениеСсылка. Опе-рация

Вид операции

Вид ОН

СправочникСсылка. Вид-ОН

Вид ОН

Город

СправочникСсылка. Города

Город

Район

СправочникСсылка. Райо-ны

Район

Улица

СправочникСсылка. Улицы

Улица

Дом

Строка, длина 5

Дом

Квартира

Строка, длина 5

Квартира

Комнат

Число, длина 2, неотр.

Количество комнат

Общая

Число, длина 4, точность 1, неотр

Общая площадь

Жилая

Число, длина 4, точность 1, неотр

Жилая площадь

Кухня

Число, длина 4, точность 1, неотр

Площадь кухни

Потолок

Число, длина 4, точность 1, неотр

Высота потолка

ПланировкаДома

СправочникСсылка. Плани-ровкаДома

Планировка дома

Этаж

Число, длина 2, неотр.

Этаж

Этажность

Число, длина 2, неотр.

Этажность

ГодПостройки

Число, длина 4, неотр.

Год постройки

Состояние

СправочникСсылка. Сос-тояние

Состояние

Санузел

ПеречислениеСсылка. Сан-узел

Вид санузла

Водоснабжение

СправочникСсылка. Водо-снабжение

Водоснабжение

Отопление

СправочникСсылка. Отоп-ление

Отопление

Телефон

Булево

Наличие телефона

Газ

Булево

Наличие газа

Канализация

Булево

Наличие канализации

Лифт

Булево

Наличие лифта

Мусоропровод

Булево

Наличие мусоропровода

Свободна

Булево

Признак «свободна»

Цена

Число, длина 10, точность 2, неотр.

Цена

Комментарий

строка, длина неограниченная

Комментарий

Продана

Булево

Признак «продана»

Агент

СправочникСсылка. Сот-рудники

Агент

Также данный документ содержит табличную часть «Владельцы» для ввода и хранения ссылок на продавцов (арендодателей) объекта недвижимости. Необходимость использования табличной части обусловлена тем, что часто встречаются случаи, когда владение является групповым, т. е. каждый участник владения имеет право распоряжаться определенной долей недвижимости. Данная табличная часть имеет два реквизита:

· «УчастникВладения», типа СправочникСсылка. Клиенты;

· «ДоляУчастия», типа строка, длина 5.

Для проведения данного документа предназначен регистр накопления «Объекты недвижимости», в котором предполагается хранить введенные данные об объектах недвижимости. На основе данного регистра построен отчет «Выбор ОН», который представляет собой выборку по необходимым параметрам, осуществляя тем самым поиск подходящих вариантов недвижимости.

После согласия клиента на покупку (аренду) находящегося в базе данных агентства объекта, агент вводит документ «Спрос» на основании соответствующего документа «Предложение». Этот объект конфигурации содержит ряд реквизитов, представленных в таблице 6.

Таблица 6 Реквизиты документа «Спрос»

Реквизит

Тип

Хранимые данные

Предложение

ДокументСсылка. Предложение

Ссылка на документ «Предложение»

Операция

ПеречислениеСсылка. Операция

Вид операции

СтоимостьПокупки

Число, длина 10, точность 2, неотр.

Стоимость ОН/аренды

Процент

Число, длина 4, точность 1, неотр

Процент от сделки

СтоимостьУслуги

Число, длина 10, точность 2, неотр.

Стоимость услуги

Агент

СправочникСсылка. Сотрудники

Агент

Комментарий

строка, длина неограниченная

Комментарий

Реквизит «Процент» предполагается заполнять на основании данных регистра сведений «Процент», который содержит информацию о размере оплаты услуг в виде стоимости сделки (ресурс «Процент», типа число, длина 4, точность 1, неотрицательное) в разрезе видов операций (измерение «Операция», типа ПеречислениеСсылка. Операция).

Документ «Спрос» должен содержать обработку проведения документа «Преложение», на основании которого он был создан, а также при проведении делать запись в регистре накопления «Услуги».

Данный регистр предназначен для хранения информации о предоставленных платных услугах агентством. На основании его формируется отчет «Услуги».

Следует также отметить необходимость создания макетов для каждого из документов. Это связано с тем, что при вводе документа «Предложение» фактически подписывается соглашение между агентством и продавцами (арендодателями). Данный бумажный документ целесообразно формировать с помощью разрабатываемой автоматизированной системы. Аналогично при вводе документа «Спрос» фактически подписывается договор по оказанию услуг между агентством и покупателями (арендаторами).

3. Разработка автоматизированной системы учета риэлтерских операций

Разработка автоматизированной системы учета риэлторских операций производится на основании спроектированных в предыдущем разделе объектов конфигурации. Рассмотрим их создание подробнее.

3.1 Создание объектов типа «Константа», «Справочник», «Перечисление», «Регистр сведений»

Для работы с постоянной и условно постоянной информацией, имеющей единственное значение, в конфигурации предусмотрен объект «Константа». Создание определенных ранее констант выполняется путем внесения в свойства вновь созданного объекта таких данных, как имя, синоним и тип.

Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа «Справочник».

Создание каждого из спроектированных справочников производится в несколько этапов:

1. На закладке «Основные» диалогового окна редактирования справочника задается определённое для каждого из них имя.

2. На закладке «Данные» вносятся определённые для справочников реквизиты, а также длина кода и наименования.

3. На закладке «Формы» были созданы основные формы представления справочников, а также выбирались способы редактирования справочников.

Справочники «Сотрудники» и «Клиенты» имеют много реквизитов, поэтому для ввода и редактирования элементов необходима форма элемента. Другие справочники имеют простую структуру, поэтому для них такая форма не предусмотрена — ввод и редактирование элементов осуществляется в списке.

Форма элемента справочника «Сотрудники» приведена на рисунке 1.

Рисунок 1. Форма элемента справочника «Сотрудники»

Логично предположить, что реквизит «ПолноеНаименование» будет вводиться как расширенное значение реквизита «Наименование», поэтому в модули формы можно прописать процедуру для вставки в поле ввода «ПолноеНаименование» значения поля «Наименование» при изменении такового:

Процедура НаименованиеПриИзменении (Элемент)

ЭлементыФормы. ПолноеНаименование. Значение = Элемент. Значение;

КонецПроцедуры

Использование тех или иных реквизитов справочника «Клиенты» зависит от того, данные какого лица, физического или юридического, заносятся в данный момент. Поэтому обосновано менять форму для ввода и редактирования элемента в зависимости от выбора значения перечисления в поле «ЮрФизЛицо». Для этого в модуль формы записывается процедура обработки события изменения данного поля. Она выглядит следующим образом:

Процедура ЮрФизЛицоПриИзменении (Элемент)

Если ЭлементыФормы. ЮрФизЛицо. Значение = Перечисления. ЮрФизЛицо. ЮрЛицо Тогда

ЭлементыФормы. Панель1. Страницы. Страница1. Видимость = Ложь;

ЭлементыФормы. Панель1. Страницы. Страница2. Видимость = Истина;

Иначе ЭлементыФормы. Панель1. Страницы. Страница2. Видимость = Ложь;

ЭлементыФормы. Панель1. Страницы. Страница1. Видимость = Истина;

КонецЕсли

КонецПроцедуры

При этом на странице 1 панели располагаются реквизиты используемые только для внесения данных о физическом лице, а на странице 2 — данных о юридическом лице. На рисунке 2 приведена форма элемента справочника «Клиенты» при выборе в поле «ЮрФизЛицо» значения «ФизЛицо», а на рисунке 3 — при выборе значения «ЮрЛицо».

Рисунок 2. Форма элемента справочника «Клиенты» при значении «ФизЛицо»

Рисунок 3. Форма элемента справочника «Клиенты» при значении «ЮрЛицо»

Такая же процедура выполняется и при открытии элемента. Так же при изменении данных реквизита «Наименование» происходит заполнение реквизита «НаименованиеПолное» этими данными аналогично как и в форме элемента справочника «Сотрудники».

Перечисления используются в системе 1С: Предприятие для описания постоянных наборов значений, не изменяемых в процессе работы конфигурации. При создании перечислений в диалоговом окне редактирования на закладке «Основные» описаны имя и синоним, а на закладке «Данные» — значения перечисления. Объект конфигурации «Регистр сведений» является прикладным объектом и предназначен для описания структуры хранения данных в разрезе нескольких измерений. При создании регистра сведений «Процент» на закладке «Основные» заданы имя регистра и его периодичность: «В пределах секунды», а на закладке «Данные» определены измерения и ресурсы данного регистра.

3.2 Создание объектов типа «Документ», «Регистр накопления», «Отчет»

Документы предназначены для отражения хозяйственных событий предприятия, которые имеют отношение к автоматизируемой предметной области. Все документы характеризуются номером и датой. Каждый документ может иметь неограниченное количество реквизитов и табличных частей, которые задаются на закладке «Данные» окна редактирования объекта. В разрабатываемой системе предполагаются два документа: «Предложение» и «Спрос». Множество реквизитов и табличных частей было определено в процессе проектирования.

Так же для документа создаются формы ввода — экранные аналоги реальных документов. Рассмотрим их создание детальней.

Документ «Предложение» имеет много реквизитов, поэтому целесообразно поместить поля ввода на двух вкладках. Форма данного документа представлена на рисунках 4 и 5.

Рисунок 4. Форма документа «Предложение», вкладка «Основные данные»

Рисунок 5. Форма документа «Предложение», вкладка «Дополнительно»

На форме также расположена кнопка «Печать», при нажатии которой из модуля объекта вызывается процедура «Печать». Данная процедура формирует макет, соответствующий форме бумажного документа «Соглашение о представлении интересов продавца (арендодателя) при продаже (сдаче в аренду) недвижимого имущества». Текст процедуры, а также печатная форма приведены в приложении 1.

Форма документа «Спрос» приведена на рисунке 6.

Рисунок 6. Форма документа «Спрос»

Для удобства заполнения данной формы реализована процедура обработки заполнения на основании документа «Предложение». Данная процедура формируется с помощью конструктора ввода на основании. Текст данной процедуры выглядит следующим образом:

Процедура ОбработкаЗаполнения (Основание)

Если ТипЗнч (Основание) = Тип («ДокументСсылка. Предложение») Тогда

// Заполнение шапки

Операция = Основание. Операция;

Предложение = Основание. Ссылка;

СтоимостьПокупки = Основание. Цена;

КонецЕсли;

Процент = Процент (Дата, Операция);

СтоимостьУслуги = РасчетСтоимостиУслуги (СтоимостьПокупки, Процент);

КонецПроцедуры

Элемент формы «Процент» заполняется автоматически при изменении элемента «Операция» путем вызова в модуле формы функции из общего модуля «Работа с документами», которая выглядит следующим образом:

Функция Процент (АктуальнаяДата, Операция) Экспорт

Отбор = Новый Структура («Операция», Операция);

ЗначенияРесурсов = РегистрыСведений. Процент. ПолучитьПоследнее (АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов. Процент;

КонецФункции

Следует отметить, что изменение элемента «Операция» происходит и при вводе документа на основании. Поэтому данную функцию следует вызывать из процедуры обработки заполнения на основании в модуле объекта.

Элемент формы «СтоимостьУслуги» рассчитывается на основании данных элементов формы «СтоимостьПокупки» и «Процент». Поэтому при изменении данных элементов вызывается функция расчета стоимости услуги из общего модуля «Работа с документами», которая выглядит следующим образом:

Функция РасчетСтоимостиУслуги (СтоимостьПокупки, Процент) Экспорт

СтоимостьУслуги = СтоимостьПокупки*Процент/100;

Возврат СтоимостьУслуги;

КонецФункции

Также как и элемент «Операция», элемент «СтоимостьПокупки» изменяется при введении документа на основании, поэтому так же, как и функция «Процент», данная функция вызывается из процедуры обработки заполнения на основании в модуле объекта.

Аналогично документу «Предложение», на форме документа «Спрос» расположена кнопка «Печать», при нажатии которой из модуля объекта вызывается процедура «Печать». Данная процедура формирует макет, соответствующий форме бумажного документа «Договор по оказанию услуг». Текст процедуры, а также печатная форма приведены в приложении 2.

Созданные документы «Предложение» и «Спрос» проводятся по регистрам накопления «Объекты недвижимости» и «Услуги» соответственно. Рассмотрим создание данных регистров.

Объект конфигурации «Регистр накопления» является прикладным объектом и предназначен для описания структуры накопления данных. На основе этого объекта платформа создает в базе данных информационную структуру, в которой будут накапливаться данные, «поставляемые» различными объектами базы данных. Эти данные будут храниться в регистре в виде отдельных записей, каждая из которых имеет одинаковую, заданную в конфигураторе структуру.

После создания оборотного регистра накопления «Объекты недвижимости» с помощью диалогового окна редактирования, объявления его реквизитов на закладке «Данные», а также указания на закладке «Регистраторы» документа «Предложение» необходимо создать процедуру проведения документа по данному регистру. Это можно сделать с помощью конструктора движения, который вызывается из диалогового окна редактирования документа «Предложение». Окно конструктора движения представлено на рисунке 7.

Рисунок 7. Окно конструктора движения для документа «Заявка»

Конструктор движения автоматически формирует текст процедуры обработки проведения и записывает ее в модуль документа. Текст данной процедуры приведен в приложении 3. Для удобного просмотра данных в регистре создается форма списка.

После введения документа «Спрос» на основании определенного документа «Предложение» запись, сформированную последним в регистре «Объекты недвижимости», следует удалить, т.к. в регистре находятся данные только о тех объектах, которые выставление на рассмотрение потенциальным покупателям (арендаторам). Это действие целесообразно реализовать путем помещения на форму документа «Спрос» специальной кнопки «Выполнить», связанной с процедурой «ОсновныеДействияФормыДействие (Кнопка)». Текст данной процедуры выглядит следующим образом:

Процедура ОсновныеДействияФормыДействие (Кнопка)

Объект = ЭлементыФормы. Предложение. Значение. ПолучитьОбъект ();

Объект. Продана = Истина;

Объект. Проведен = Ложь;

Объект. Записать (РежимЗаписиДокумента. ОтменаПроведения);

КонецПроцедуры

В ходе выполнения процедуры, кроме отмены проведения документа «Предложение», проводится изменение реквизита этого документа «Продана» на значение «Истина».

Также в процессе проектирования был определен еще один оборотный регистр «Услуги», в котором записи формируются при проведении документа «Спрос». Поэтому после создания данного регистра вызывается конструктор движения для данного документа, который формирует процедуру обработки проведения в модули объекта, текст которой приведен в приложении 3. На рисунке 8 представлено окно конструктора.

Рисунок 8. Окно конструктора движения для документа «Спрос»

На основе созданных регистров формируются два отчета «Выбор ОН» и «Услуги». Рассмотрим их разработку подробнее.

Отчёты создаются с помощью конструктора выходных форм, который вызывается из окна редактирования объекта «Отчёт». Отчет «Выбор ОН» в качестве источника данных для запроса выступают данные из регистра накопления «Объекты ОН». Т.к. основной задачей отчета является выбор отдельных строк из регистра по определенным параметрам, на закладке «Условия» определяются поля, по которым будет производиться выборка. Данная закладка представлена на рисунке 9.

Рисунок 9. Окно конструктора выходных форм отчёта «Выбор ОН»

На закладке «Выходная форма» следует отметить, что данные параметры редактируются в форме. При работе с параметрами может понадобиться отбор по какому-либо иному полю, поэтому в конструкторе указывается использование формы настройки отчета и в качестве ее состава выбирается «Отбор».

Т.к. введение параметров, редактируемых в форме отчета обязательно, целесообразно при открытии формы отчета присваивать параметру «Конечная цена» максимально возможное значение. Данная процедура выглядит следующим образом:

Процедура ПриОткрытии ()

КонечнаяЦена = «99 999 999,99»;

КонецПроцедуры

Вследствие этого в случае невведения по каким-либо причинам параметров «Начальная цена» и «Конечная цена» в форму выборка будет осуществляться по всем допустимым значениям реквизита «Цена».

Выходная форма отчета «Выбор ОН» представлена на рисунке 10.

Рисунок 10. Выходная форма отчета «Выбор ОН»

Выходная форма отчета «Услуги» создается также при помощи конструктора. В источника данных выбирается «Услуги. Обороты». На закладке «Итоги» указывается группировочное поле «Агент», а в качестве итогового выступает «СтоимостьУслугиОборот». Данная закладка представлена на рисунке 11.

Рисунок 11. Окно конструктора выходных форм отчёта «Услуги»

На закладке «Выходная форма» указывается факт редактирования в форме параметров «ДатаНачала» и «ДатаОкончания». В результате конструктор формирует форму отчета, которая представлена на рисунке 11, и макет.

Рисунок 11. Выходная форма отчета «Услуги»

Конечным этапом разработки стала создание удобного интерфейса.

Заключение

В данной курсовой работе было рассмотрено анализ деятельности риэлторской фирмы, разработка функциональных требований к автоматизированной системе учета риэлторских операций, а также ее проектирование и разработка автоматизированной системы с помощью использования платформы «1С: Предприятие 8. 0».

В первом разделе были проанализированы предметная область и работа риелторской фирмы, и в соответствии с этим были выведены процессы деятельности риэлтора, требующие автоматизации.

Во втором разделе были определены объекты конфигурации, предназначенные для ввода, хранения, обработки и вывода информации о клиентах агентства, объектах недвижимости, предоставляемых услугах, а также других данных, необходимых для работы риэлтора. Также была спроектирована связь между этими объектами.

В третьем разделе было произведено создание конфигурации «Риэлтор» путем разработки спроектированных во втором разделе объектов конфигурации и взаимодействия между ними, а также пользовательского интерфейса для удобства доступа к данным объектам.

В результате можно выделить следующую последовательность использования разработанных объектов в процессе деятельности риэлтора:

· При поступлении предложения от клиента создается новый элемент справочника «Клиенты» и документ «Предложение», который содержит процедуру печати бумажного документа «Соглашение о предоставлении интересов продавца (арендодателя)». Данный документ при проведении формирует запись в регистре накопления «Объекты недвижимости»

· При появлении потенциальных покупателей (арендаторов) с помощью отчета «Выбор ОН», формируемого на основе регистра накопления «Объекты недвижимости», подбирается подходящие варианты.

· При согласии клиента приобрести (арендовать) определенный объект недвижимости создается новый элемент справочника «Клиенты» и на основании соответствующего документа «Предложение» вводится документ «Спрос», который содержит обработку отмены проведения первого. Данный документ содержит процедуру печати бумажного документа «Договор по оказанию услуг». При проведении он формирует запись в оборотном регистре накопления «Услуги», на основе которого формируется отчет «Услуги».

Таким образом, задача данной курсовой работы (создание автоматизированной системы учета риэлторских операций) была выполнена.

Список использованных источников

1. Митичкин С. А. Разработка в системе 1С: Предприятие 8.0.- М.: ООО «1С-Паблишинг», 2003.- 500 с.

2. Радченко М. Г. 1С: Предприятие 8.0. Практическое пособие разработчика. Примеры и типовые приёмы.- М.: ООО «1С-Паблишинг», 2004.- 656 с., ил.

3. comfort. kiev. ua

4. deal. real. ru

5. wmakler. chat. ru

6. exsoft. perm. ru

7. reesag. chat. ru

Приложение

Текст процедуры «Печать ()», макет и предварительный просмотр документа «Предложение»

Процедура Печать () Экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = Документы. Предложение. ПолучитьМакет («Печать»);

// Заголовок

Область = Макет. ПолучитьОбласть («Заголовок»);

ТабДок. Вывести (Область);

// Текст

Область = Макет. ПолучитьОбласть («Текст»);

Если Операция = Перечисления. Операция. ПокупкаПродажа Тогда

Область. Параметры. Продавцы = «продавцы»;

Область. Параметры. Операция = «продажи»;

Иначе Область. Параметры. Продавцы = «арендодатели»;

Область. Параметры. Операция = «сдачи в аренду»;

КонецЕсли;

Область. Параметры. Дата = Формат (Дата, «ДЛФ=ДД»);

Область. Параметры. Адрес = Константы. Адрес. Получить ();

Область. Параметры. Телефоны = Константы. Телефоны. Получить ();

Область. Параметры. НазваниеОрганизации = Константы. НазваниеОрганизации. Получить ();

Область. Параметры. АгентПолное = Агент. ПолноеНаименование;

ТабДок. Вывести (Область);

// Владельцы

Для Каждого ТекСтрокаВладельцы Из Владельцы Цикл

Область = Макет. ПолучитьОбласть («Владельцы»);

Если ТекСтрокаВладельцы. УчастникВладения. ЮрФизЛицо = Перечисления. ЮрФизЛицо. ФизЛицо Тогда

Область. Параметры. УчастникВладения = ТекСтрокаВладельцы. УчастникВладения. НаименованиеПолное;

Иначе Область. Параметры. УчастникВладения = ТекСтрокаВладельцы. УчастникВладения. НаименованиеПолное + «, представителем которого является «+ ТекСтрокаВладельцы. УчастникВладения. Представитель;

КонецЕсли;

ТабДок. Вывести (Область);

КонецЦикла;

// Текст1

Область = Макет. ПолучитьОбласть («Текст1»);

Если Операция = Перечисления. Операция. ПокупкаПродажа Тогда

Область. Параметры. Продавец = «Продавец»;

Область. Параметры. Операция = «продажи»;

Область. Параметры. Покупателями = «покупателями»;

Область. Параметры. Продавца = «Продавца»;

Область. Параметры. ОбъектПередачи = «права собственности на»;

Область. Параметры. Покупателю = «покупателю»;

Область. Параметры. ОбъектаСоглашения = «Недвижимости»;

Иначе Область. Параметры. Продавец = «Арендодатель»;

Область. Параметры. Операция = «сдачи в аренду»;

Область. Параметры. Покупателями = «арендаторами»;

Область. Параметры. Продавца = «Арендодателя»;

Область. Параметры. ОбъектПередачи = «в аренду»;

Область. Параметры. Покупателю = «арендатору»;

Область. Параметры. ОбъектаСоглашения = «аренды Недвижимости»;

КонецЕсли;

Область. Параметры. ВидОН = ВидОН;

Область. Параметры. Город = Город. ТипНаселенногоПункта. Наименование + «» + Город;

Область. Параметры. Улица = Улица. ТипУлицы. Наименование + «» + Улица;

Область. Параметры. Дом = Дом;

Если Квартира = «» Тогда

Иначе Область. Параметры. Квартира = «, кв. «+ Квартира;

КонецЕсли;

ПарПредмета = «рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2»;

Область. Параметры. Цена = Цена;

Область. Параметры. ЦенаПрописью = ЧислоПрописью (Цена, «Л = ru_RU», ПарПредмета);

Область. Параметры. Дата = Формат (Дата, «ДЛФ=ДД»);

Область. Параметры. Агент = Агент;

Область. Параметры. НаименованиеОрганизации = Константы. НазваниеОрганизации. Получить ();

Область. Параметры. ИННОрганизации = Константы. ИНН. Получить ();

Область. Параметры. КППОрганизации = Константы. КПП. Получить ();

Область. Параметры. АдресОрганизации = Константы. Адрес. Получить ();

Область. Параметры. ТелефоныОрганизации = Константы. Телефоны. Получить ();

Область. Параметры. РасчетныйСчет = Константы. РасчетныйСчет. Получить ();

ТабДок. Вывести (Область);

// Владельцы1

Для Каждого ТекСтрокаВладельцы Из Владельцы Цикл

Область = Макет. ПолучитьОбласть («Владельцы1»);

Область. Параметры. НаименованиеПродавца = ТекСтрокаВладельцы. УчастникВладения. НаименованиеПолное;

Область. Параметры. АдресПродавца = ТекСтрокаВладельцы. УчастникВладения. Адрес;

Область. Параметры. ТелефонПродавца = ТекСтрокаВладельцы. УчастникВладения. Телефон;

Если ТекСтрокаВладельцы. УчастникВладения. ЮрФизЛицо = Перечисления. ЮрФизЛицо. ФизЛицо Тогда

Область. Параметры. Параметр1 = «дата р.» + ТекСтрокаВладельцы. УчастникВладения. ДатаРождения;

Область. Параметры. Параметр2 = ТекСтрокаВладельцы. УчастникВладения. Документ;

Иначе Область. Параметры. Параметр1 = «ИНН «+ ТекСтрокаВладельцы. УчастникВладения. ИНН;

Область. Параметры. Параметр2 = «КПП «+ ТекСтрокаВладельцы. УчастникВладения. КПП;

Область. Параметры. Представитель = ТекСтрокаВладельцы. УчастникВладения. Представитель;

КонецЕсли;

ТабДок. Вывести (Область);

КонецЦикла;

ТабДок. ОтображатьСетку = Ложь;

ТабДок. Защита = Ложь;

ТабДок. ТолькоПросмотр = Ложь;

ТабДок. ОтображатьЗаголовки = Ложь;

ТабДок. Показать ();

КонецПроцедуры

Приложение 2

Текст процедуры «Печать ()», макет и предварительный просмотр документа «Спрос»

Процедура Печать () Экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = Документы. Спрос. ПолучитьМакет («Печать»);

// Заголовок

Область = Макет. ПолучитьОбласть («Заголовок»);

Область. Параметры. Номер = Номер;

ТабДок. Вывести (Область);

// Текст

Область = Макет. ПолучитьОбласть («Текст»);

Область. Параметры. Дата = Формат (Дата, «ДЛФ=ДД»);

Область. Параметры. Адрес = Константы. Адрес. Получить ();

Область. Параметры. Телефоны = Константы. Телефоны. Получить ();

Область. Параметры. НазваниеОрганизации = Константы. НазваниеОрганизации. Получить ();

Область. Параметры. АгентПолное = Агент. ПолноеНаименование;

ТабДок. Вывести (Область);

//Клиенты

Для Каждого ТекСтрокаПокупатели Из Покупатели Цикл

Область = Макет. ПолучитьОбласть («Клиенты»);

Если ТекСтрокаПокупатели. УчастникПокупки. ЮрФизЛицо = Перечисления. ЮрФизЛицо. ФизЛицо Тогда

Область. Параметры. УчастникПокупки = ТекСтрокаПокупатели. УчастникПокупки. НаименованиеПолное;

Иначе Область. Параметры. УчастникПокупки = ТекСтрокаПокупатели. УчастникПокупки. НаименованиеПолное + «, представителем которого является «+ ТекСтрокаПокупатели. УчастникПокупки. Представитель;

КонецЕсли;

ТабДок. Вывести (Область);

КонецЦикла;

//Текст1

Область = Макет. ПолучитьОбласть («Текст1»);

Если Операция = Перечисления. Операция. ПокупкаПродажа Тогда

Область. Параметры. Операция = «покупки»;

Область. Параметры. Отчуждающего = «отчуждающего»;

Область. Параметры. Продавцами = «Продавцами»;

Иначе Область. Параметры. Операция = «аренды»;

Область. Параметры. Отчуждающего = «сдающего в аренду»;

Область. Параметры. Продавцами = «Арендодателями»;

КонецЕсли;

Область. Параметры. ВидОН = Предложение. ВидОН;

Область. Параметры. Город = Предложение. Город. ТипНаселенногоПункта. Наименование + «» + Предложение. Город;

Область. Параметры. Улица = Предложение. Улица. ТипУлицы. Наименование + «» + Предложение. Улица;

Область. Параметры. Дом = Предложение. Дом;

Если Предложение. Квартира = «» Тогда

Иначе Область. Параметры. Квартира = «, кв. «+ Предложение. Квартира;

КонецЕсли;

Область. Параметры. СтоимостьУслуги = СтоимостьУслуги;

ПарПредмета = «рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2»;

Область. Параметры. СтоимостьУслугиПрописью = ЧислоПрописью (СтоимостьУслуги, «Л = ru_RU», ПарПредмета);

Область. Параметры. Агент = Агент;

Область. Параметры. НаименованиеОрганизации = Константы. НазваниеОрганизации. Получить ();

Область. Параметры. ИННОрганизации = Константы. ИНН. Получить ();

Область. Параметры. КППОрганизации = Константы. КПП. Получить ();

Область. Параметры. АдресОрганизации = Константы. Адрес. Получить ();

Область. Параметры. ТелефоныОрганизации = Константы. Телефоны. Получить ();

Область. Параметры. РасчетныйСчет = Константы. РасчетныйСчет. Получить ();

Область. Параметры. Агент = Агент;

ТабДок. Вывести (Область);

// Клиенты1

Для Каждого ТекСтрокаПокупатели Из Покупатели Цикл

Область = Макет. ПолучитьОбласть («Клиенты1»);

Область. Параметры. НаименованиеКлиента = ТекСтрокаПокупатели. УчастникПокупки. НаименованиеПолное;

Область. Параметры. АдресКлиента = ТекСтрокаПокупатели. УчастникПокупки. Адрес;

Область. Параметры. ТелефонКлиента = ТекСтрокаПокупатели. УчастникПокупки. Телефон;

Если ТекСтрокаПокупатели. УчастникПокупки. ЮрФизЛицо = Перечисления. ЮрФизЛицо. ФизЛицо Тогда

Область. Параметры. Параметр1 = «дата р.» + ТекСтрокаПокупатели. УчастникПокупки. ДатаРождения;

Область. Параметры. Параметр2 = ТекСтрокаПокупатели. УчастникПокупки. Документ;

Иначе Область. Параметры. Параметр1 = «ИНН «+ ТекСтрокаПокупатели. УчастникПокупки. ИНН;

Область. Параметры. Параметр2 = «КПП «+ ТекСтрокаПокупатели. УчастникПокупки. КПП;

Область. Параметры. Представитель = ТекСтрокаПокупатели. УчастникПокупки. Представитель;

КонецЕсли;

ТабДок. Вывести (Область);

КонецЦикла;

ТабДок. ОтображатьСетку = Ложь;

ТабДок. Защита = Ложь;

ТабДок. ТолькоПросмотр = Ложь;

ТабДок. ОтображатьЗаголовки = Ложь;

ТабДок. Показать ();

КонецПроцедуры

Приложение 3

Текст процедуры проведения документа «Предложение»

Процедура ОбработкаПроведения (Отказ, Режим)

Движение = Движения. ОбъектыНедвижимости. Добавить ();

Движение. Период = Дата;

Движение. Операция = Операция;

Движение. ВидОН = ВидОН;

Движение. Город = Город;

Движение. Район = Район;

Движение. Улица = Улица;

Движение. Дом = Дом;

Движение. Квартира = Квартира;

Движение. Комнат = Комнат;

Движение. Общая = Общая;

Движение. Жилая = Жилая;

Движение. Кухня = Кухня;

Движение. ПланировкаДома = ПланировкаДома;

Движение. Потолок = Потолок;

Движение. Этаж = Этаж;

Движение. Этажность = Этажность;

Движение. Состояние = Состояние;

Движение. Санузел = Санузел;

Движение. Водоснабжение = Водоснабжение;

Движение. Отопление = Отопление;

Движение. Телефон = Телефон;

Движение. Газ = Газ;

Движение. Канализация = Канализация;

Движение. Лифт = Лифт;

Движение. Мусоропровод = Мусоропровод;

Движение. Свободна = Свободна;

Движение. Цена = Цена;

Движение. Комментарий = Комментарий;

Движения. ОбъектыНедвижимости. Записать ();

КонецПроцедуры

Текст процедуры проведения документа «Спрос»

Процедура ОбработкаПроведения (Отказ, Режим)

Движение = Движения. Услуги. Добавить ();

Движение. Период = Дата;

Движение. Агент = Агент;

Движение. СтоимостьУслуги = СтоимостьУслуги;

Движения. Услуги. Записать ();

КонецПроцедуры

ПоказатьСвернуть
Заполнить форму текущей работой